Bug 4098 - "net user add" adds a disabled user account
"net user add" adds a disabled user account
Status: RESOLVED FIXED
Product: Samba 3.4
Classification: Unclassified
Component: Build environment
3.4.0
x86 Linux
: P3 major
: ---
Assigned To: Jim McDonough
Samba QA Contact
:
: 502 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 11:29 UTC by ClemLass
Modified: 2009-11-30 07:30 UTC (History)
4 users (show)

See Also:


Attachments
Quick hack to create accounts which aren't disabled (2.52 KB, patch)
2006-11-13 17:48 UTC, Joe Mondloch
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description ClemLass 2006-09-13 11:29:35 UTC
The bug with ID 502 still exists with samba 3.0.22 and 3.0.23c : while adding a user via rpc ("net rpc user add") on a Win2k SP4 DC (or on a Win2k3 SP1 DC), the user is created but is disabled.
Thanks.
Comment 1 Gerald (Jerry) Carter 2006-09-13 11:58:57 UTC
*** Bug 502 has been marked as a duplicate of this bug. ***
Comment 2 Pete Boyd 2006-11-10 03:02:53 UTC
When I add users to a Debain 3.1 Sarge (Samba 3.0.14a) PDC with these commands:

net rpc user add <username> -S <server hostname> -U <user to connect as>
net rpc password <username> <password> -U <user to connect as>

the account is disabled.

'pdbedit -c -u <username>' does not say the account is disabled. 'smbpasswd -e <username> -U winadmin' enables it.


Comment 3 Joe Mondloch 2006-11-13 17:48:40 UTC
Created attachment 2216 [details]
Quick hack to create accounts which aren't disabled
Comment 4 Pete Boyd 2006-11-15 16:07:18 UTC
I don't read C very well but from the looks of it are you saying that the account is disabled if its created without a password and the password is created seperately?

I create the account and set the password with a second command because I couldn't get the command to work when all done together.
Comment 5 Karolin Seeger 2009-11-30 07:09:56 UTC
This is still an issue in Samba 3.4. Raising version number.
Comment 6 Karolin Seeger 2009-11-30 07:29:12 UTC
(In reply to comment #5)
> This is still an issue in Samba 3.4. Raising version number.
> 

Added this comment to the wrong bug report. Sorry!
Comment 7 Karolin Seeger 2009-11-30 07:30:56 UTC
Just tried to reproduce with Samba 3.4.3 and it's no longer an issue.
Closing out bug report.

Thanks for reporting!