Bug 4832 - iconv library is not used.
iconv library is not used.
Status: RESOLVED FIXED
Product: Samba 3.4
Classification: Unclassified
Component: Build environment
3.4.0
x86 FreeBSD
: P3 major
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 4833 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-28 18:59 UTC by Tsurutani Naoki
Modified: 2009-12-09 02:26 UTC (History)
5 users (show)

See Also:


Attachments
Patch for 3.3. (4.05 KB, patch)
2009-12-04 03:07 UTC, Kai Blin
bjacke: review+
Details
Patch for 3.4 (4.06 KB, patch)
2009-12-04 03:09 UTC, Kai Blin
bjacke: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tsurutani Naoki 2007-07-28 18:59:07 UTC
I build samba on FreeBSD 6.2-STABLE, and building process
end successfully, as I see.
But libiconv is not used and no conversion happens.
I investigated the configure output, and found that
iconv library is not properly decided.
This is caused by wrong directives in aclocal.m4 file,
concerning iconv.
I installed both libiconv and libbiconv, and SVN comment
shows that biconv should be used if iconv cannot be used.
But using current aclocal.m4 file always used biconv
due to wrong branching condition.

Here is a patch:
--- aclocal.m4.orig     Thu Mar  1 13:55:17 2007
+++ aclocal.m4  Sun Jul 29 08:17:18 2007
@@ -334,7 +334,7 @@
            jm_cv_func_iconv=yes
            jm_cv_lib_iconv="")

-          if test "$jm_cv_lib_iconv" != yes; then
+          if test "$jm_cv_func_iconv" != yes; then
             jm_save_LIBS="$LIBS"
             LIBS="$LIBS -lgiconv"
             AC_TRY_LINK([#include <stdlib.h>
@@ -363,7 +363,7 @@
             jm_cv_lib_iconv="iconv")
           LIBS="$jm_save_LIBS"

-          if test "$jm_cv_lib_iconv" != yes; then
+          if test "$jm_cv_func_iconv" != yes; then
             jm_save_LIBS="$LIBS"
             LIBS="$LIBS -lbiconv"
             AC_TRY_LINK([#include <stdlib.h>
Comment 1 Tsurutani Naoki 2007-07-28 19:47:43 UTC
*** Bug 4833 has been marked as a duplicate of this bug. ***
Comment 2 Timur Bakeyev 2007-07-29 08:23:48 UTC
Hi, Jerry, Alex!

> But using current aclocal.m4 file always used biconv

I have only one question - WHY?! After we successfully buried biconv code around 3.0.20 it strikes back again. I'm sending separate letter about it now, but basically, we just need to remove this old code and never bring it back.

With regards,
Timur
Comment 3 Karolin Seeger 2009-11-30 07:02:29 UTC
Is this still an issue in Samba 3.4.3?
Comment 4 Tsurutani Naoki 2009-12-01 16:33:49 UTC
Yes, samba-3.4.3 still has a problem.
Comment 5 Karolin Seeger 2009-12-02 02:12:29 UTC
Updating component.
Thanks for the feedback!
Comment 6 Kai Blin 2009-12-04 03:07:49 UTC
Created attachment 5053 [details]
Patch for 3.3.

Patch for 3.3.X
Comment 7 Kai Blin 2009-12-04 03:09:21 UTC
Created attachment 5054 [details]
Patch for 3.4

Patch for 3.4.X
Comment 8 Kai Blin 2009-12-04 03:15:00 UTC
Pushed fixes to master and v3-5-test
Comment 9 Björn Jacke 2009-12-08 13:47:17 UTC
Comment on attachment 5054 [details]
Patch for 3.4

looks good!
Comment 10 Karolin Seeger 2009-12-09 02:26:53 UTC
Pushed patches to v3-3-test and v3-4-test.
Closing out bug report.

Thanks!