Bug 4833 - iconv library is not used.
iconv library is not used.
Status: RESOLVED DUPLICATE of bug 4832
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
3.0.25
x86 FreeBSD
: P3 major
: none
Assigned To: Alexander Bokovoy
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-28 19:28 UTC by Tsurutani Naoki
Modified: 2007-07-28 19:47 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tsurutani Naoki 2007-07-28 19:28:30 UTC
I build samba on FreeBSD 6.2-STABLE, and building process
end successfully, as I see.
But libiconv is not used and no conversion happens.
I investigated the configure output, and found that
iconv library is not properly decided.
This is caused by wrong directives in aclocal.m4 file,
concerning iconv.
I installed both libiconv and libbiconv, and SVN comment
shows that biconv should be used if iconv cannot be used.
But using current aclocal.m4 file always used biconv
due to wrong branching condition.

Here is a patch:
--- aclocal.m4.orig     Thu Mar  1 13:55:17 2007
+++ aclocal.m4  Sun Jul 29 08:17:18 2007
@@ -334,7 +334,7 @@
            jm_cv_func_iconv=yes
            jm_cv_lib_iconv="")

-          if test "$jm_cv_lib_iconv" != yes; then
+          if test "$jm_cv_func_iconv" != yes; then
             jm_save_LIBS="$LIBS"
             LIBS="$LIBS -lgiconv"
             AC_TRY_LINK([#include <stdlib.h>
@@ -363,7 +363,7 @@
             jm_cv_lib_iconv="iconv")
           LIBS="$jm_save_LIBS"

-          if test "$jm_cv_lib_iconv" != yes; then
+          if test "$jm_cv_func_iconv" != yes; then
             jm_save_LIBS="$LIBS"
             LIBS="$LIBS -lbiconv"
             AC_TRY_LINK([#include <stdlib.h>
Comment 1 Tsurutani Naoki 2007-07-28 19:47:43 UTC

*** This bug has been marked as a duplicate of 4832 ***