Bug 475 - Unable to join XP workstation to domain
Unable to join XP workstation to domain
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
All Windows XP
: P3 critical
: none
Assigned To: Gerald (Jerry) Carter
Depends on: 309
  Show dependency treegraph
Reported: 2003-09-18 11:17 UTC by Roland Gruber
Modified: 2005-11-14 09:26 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Roland Gruber 2003-09-18 11:17:16 UTC
In RC4 the joining of two WinXP workstations failed. The Windows error message
was that the domain has not been found or does not exist.
The only log messages I got from Samba were in log.nmbd:

[2003/09/18 13:51:42, 1] nmbd/nmbd_processlogon.c:process_logon_packet(95)
  process_logon_packet: Logon from code = 0x12

But no error messages.
I tried to reset the machine password with smbpasswd -a -m PC02$ and turned smb
signing in XP on and off. Nothing changed.

A WinNT4 workstation could only join the domain if the machine password was reset.

After going back to Samba Beta 3, the joining did work on both XP stations. But
there was a problem after going back to RC4, users were unable to login. After
enabling smb signing in XP, the login worked.
This is the log with disabled signing:

[2003/09/18 19:35:42, 0] rpc_server/srv_pipe.c:api_pipe_netsec_process(1357)
  failed to decode PDU
[2003/09/18 19:35:42, 0] rpc_server/srv_pipe_hnd.c:process_request_pdu(605)
  process_request_pdu: failed to do schannel processing.

So there is a problem with joining XP workstations in RC4 and another problem if
the workstations are set no to do smb signing.

part of smb.conf:

   logon drive =
   logon path =
   domain logons = yes
   domain master = yes
   local master = yes
   preferred master = yes
   ldap admin dn = cn=admin,o=bwl
   ldap machine suffix = ou=machines
   ldap user suffix = ou=People
   ldap passwd sync = yes
   ldap suffix = o=bwl
   security = user
   encrypt passwords = true
   passdb backend = ldapsam guest
   obey pam restrictions = no
Comment 1 Gerald (Jerry) Carter 2003-09-22 12:59:35 UTC
Cannot reproduce this against locally.  XP (with 
and without SP1) join fine.  Looks like this could 
be a configuration error.  Please reopen if you 
can provided more information to point to a 
different root cause.
Comment 2 Gerald (Jerry) Carter 2005-02-07 09:05:40 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 3 Gerald (Jerry) Carter 2005-11-14 09:26:41 UTC
database cleanup