Bug 309 - Can't log a winxp on to samba 3.0rc1 nt4 domain.
Can't log a winxp on to samba 3.0rc1 nt4 domain.
Status: RESOLVED DUPLICATE of bug 167
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.0preX
Other Windows XP
: P2 regression
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks: 475
  Show dependency treegraph
 
Reported: 2003-08-17 10:21 UTC by Troels Liebe Bentsen
Modified: 2005-02-07 09:06 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Troels Liebe Bentsen 2003-08-17 10:21:58 UTC
Works fine with win2k, the winxp have joined the domain, but im not able to log
on to it with a user.
I get(Logon Message):
The system cannot log you on due to the following error:

 The Procedure number is out of range.

and this on the smb end:
[2003/08/17 18:57:48, 0] rpc_server/srv_samr.c:api_samr_set_userinfo(790)
  api_samr_set_userinfo: Unable to unmarshall SAMR_Q_SET_USERINFO.
[2003/08/17 19:02:55, 0] rpc_server/srv_pipe.c:api_pipe_netsec_process(1343)
  Invalid auth info 68 or level 5 on schannel
[2003/08/17 19:02:55, 0] rpc_server/srv_pipe_hnd.c:process_request_pdu(605)
  process_request_pdu: failed to do schannel processing.
[2003/08/17 19:02:55, 0] rpc_server/srv_pipe.c:api_pipe_netsec_process(1343)
  Invalid auth info 68 or level 5 on schannel
[2003/08/17 19:02:55, 0] rpc_server/srv_pipe_hnd.c:process_request_pdu(605)
  process_request_pdu: failed to do schannel processing.
[2003/08/17 19:03:12, 0] rpc_server/srv_pipe.c:api_pipe_netsec_process(1343)
  Invalid auth info 68 or level 5 on schannel
[2003/08/17 19:03:12, 0] rpc_server/srv_pipe_hnd.c:process_request_pdu(605)
  process_request_pdu: failed to do schannel processing.
[2003/08/17 19:03:12, 0] rpc_server/srv_pipe.c:api_pipe_netsec_process(1343)
  Invalid auth info 68 or level 5 on schannel
[2003/08/17 19:03:12, 0] rpc_server/srv_pipe_hnd.c:process_request_pdu(605)
  process_request_pdu: failed to do schannel processing.
[2003/08/17 19:05:11, 0] lib/util_sock.c:read_socket_data(342)
  read_socket_data: recv failure for 4. Error = Connection reset by peer
Comment 1 Gerald (Jerry) Carter 2003-08-18 11:07:40 UTC
Please provide a full level 10 debug (set "debug timestamp = no"
to trim size), smb.conf, and possible a network trace 
(tcpdump -s 0 -w bug309.pcap -i eth0 host <ip.addr of xp client>).
You can send these to me directly if you want or attach them to 
this bug if they are not excessively large.

I've tried to reproduce this with no luck so far.
Comment 2 Gerald (Jerry) Carter 2003-08-18 23:08:14 UTC
After looking at a trace, it appears that a 2k client (joined 
to the mixed mode domain, but the logged on user is from AQUA)
is only negotiating NTLMSSP.

My domain structure is:

VALE                 SAMBA domain
GLASS                NT4
AD.PLAINJOE.ORG      native
    +----FRUIT       mixed
    +----FROST       native
         +-----AQUA  native
Comment 3 Gerald (Jerry) Carter 2003-08-19 11:26:58 UTC
Doh!  wrong comment.  Should have been applied to Bug #305 I think.
Comment 4 Gerald (Jerry) Carter 2003-08-27 13:05:18 UTC
RC2 will ship with this issue unresolved.  We'll put it on 
the plate for RC3 and hope to resolve it by then.
Comment 5 Gerald (Jerry) Carter 2003-08-29 08:15:02 UTC
Haven't had any supporting claims of this bug.
I think there is a configuration error somewhere here.
Comment 6 Gerald (Jerry) Carter 2003-08-29 09:14:54 UTC
a couple of reports from the samba mailing list 
so I've reopened this.  Waiting on logs.
Comment 7 Andrej Drobnic 2003-09-05 05:47:49 UTC
Getting "The procedure number is out of range" error on WinXP Professional SP1.

level 10 samba logs:
http://freeweb.siol.net/hatch/log.overkill
http://freeweb.siol.net/hatch/log.smb
Comment 8 Tim Potter 2003-09-14 17:46:27 UTC
Cleared target milestone field.
Comment 9 Gerald (Jerry) Carter 2003-09-19 11:56:47 UTC
Neither one of the log files mentioned in
comment #7 are available.  Can you send them 
to me directly or tar and gzip them as 
an attachment to this bug?
Comment 10 Gerald (Jerry) Carter 2003-09-20 08:15:09 UTC
Problem seens to be a schannl issue:

process_incoming_data: Start: pdu_received_len = 0, pdu_needed_len = 304,
incoming data = 304
process_complete_pdu: processing packet type 0
000000 smb_io_rpc_hdr_req req
    0000 alloc_hint: 000000f4
    0004 context_id: 0000
    0006 opnum     : 0002
data 256 auth 32
000108 smb_io_rpc_hdr_auth hdr_auth
    0108 auth_type    : 44
    0109 auth_level   : 05
    010a padding      : 0c
    010b reserved     : 00
    010c auth_context : 000b1ca8
Invalid auth info 68 or level 5 on schannel
process_request_pdu: failed to do schannel processing.
set_incoming_fault: Setting fault state on pipe NETLOGON : vuid = 0x64
process_complete_pdu: DCE/RPC fault sent on pipe lsass
set_incoming_fault: Setting fault state on pipe NETLOGON : vuid = 0x64
Comment 11 Gerald (Jerry) Carter 2003-09-20 08:15:47 UTC
error on client (during logon) is "Procedure 
number is out of range".  Join seems to work ok.
Comment 12 Gerald (Jerry) Carter 2003-09-22 13:01:59 UTC
I have tried both XP and XP SP1 and cannot reproduce this.
Have tried withthe "RequireSignorSeal" registry enabled 
and disabled.  There some type of local configuration error 
I think.  

Have you done any modifications to the client?  
Comment 13 Andrew Bartlett 2003-09-26 16:21:00 UTC

*** This bug has been marked as a duplicate of 167 ***
Comment 14 Gerald (Jerry) Carter 2005-02-07 09:06:20 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.