Bug 4653 - Office 2007 Docs Saved as Read-only on Samba 3.0.22 Share (w/Roaming Profiles)
Office 2007 Docs Saved as Read-only on Samba 3.0.22 Share (w/Roaming Profiles)
Status: RESOLVED DUPLICATE of bug 1861
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.22
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-23 14:54 UTC by deann corum
Modified: 2012-05-11 13:25 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description deann corum 2007-05-23 14:54:14 UTC
Like many Samba users, we do NOT have our profiles and home directories in seperate shares - they are all in one. Users of Office 2007 are experiencing issues with saving files to their home directory ONLY when using Office 2007. The files can be saved once, but when modified and saved again, the file is given a "DENY-WRITE" status (smbstatus) and is marked read-only. 

This can be FIXED however the fix BREAKS roaming profiles on installations where the users' profiles are in their home directory directory rather than seperate.  

Configuring "nt acl support = no" fixes the issue. However once that is done the user's roaming profile will no longer load. We DO have "profile acls = yes" set in the .conf file as well. Having both of these set to yes "breaks" Office 2007 in this matter when roaming profiles and Office 2007 are used - and when the users profile is in their home directory. 

The only other "fix" is for all Samba admins who put profiles within the user's home directories to move them all out and seperate them. 

I know we are not the only ones who have our homes and profiles combined in this manner and more and more folks will be using Office 2007 soon.
Comment 1 Ivan Ivanov 2008-03-12 01:54:24 UTC
Im use this share definition in this situation:

[homes]
        profile acls = yes
        path = %H
        guest ok = no
        browseable = no
        valid users = %S
        writeable = yes
        force create mode = 0664
        force directory mode = 0775
        force security mode = 0600
        csc policy = disable

FreeBSD 5.5-STABLE, samba 3.0.28 + patchs from ports tree
Comment 2 Björn Jacke 2012-05-11 13:25:38 UTC
actually profiles should be in a separate place and profile acls should only be used on profile shares

*** This bug has been marked as a duplicate of bug 1861 ***