Bug 4632 - smbmount ERRHRD - ERRgeneral (General failure.) in 3.0.25
smbmount ERRHRD - ERRgeneral (General failure.) in 3.0.25
Status: RESOLVED DUPLICATE of bug 1920
Product: Samba 3.0
Classification: Unclassified
Component: smbmount (unmaintained)
3.0.9
Other Windows XP
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-17 12:33 UTC by imacat
Modified: 2014-07-29 13:50 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description imacat 2007-05-17 12:33:08 UTC
Hi.  This is imacat from Taiwan.  I was upgrading from Samba 3.0.24 to 3.0.25.  My environment is: x86_64, Debian GNU/Linux 4.0 r0 Etch, kernel 2.6.18-4-amd64, gcc 4.1.2, glibc 2.3.6.  I encounter the following error while trying to mount with smbmount:

imacat@rinse ~ % smbmount //cotton/incoming /tmp/cotton
added interface ip=10.0.0.1 bcast=10.0.0.255 nmask=255.255.255.0
added interface ip=127.0.0.1 bcast=127.255.255.255 nmask=255.0.0.0
tdb(unnamed): tdb_open_ex: could not open file /var/lib/samba/gencache.tdb: Permission denied
Got a positive name query response from 127.0.0.1 ( 10.0.0.3 )
Password:
343: tree connect failed: ERRHRD - ERRgeneral (General failure.)
SMB connection failed
imacat@rinse ~ %

    This is what in the log file:

[2007/05/18 01:26:20, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/18 01:26:20, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/18 01:26:20, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/18 01:26:20, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/18 01:26:20, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/18 01:26:20, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/18 01:26:20, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/18 01:26:20, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/18 01:26:20, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/18 01:26:20, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/18 01:26:20, 2] passdb/lookup_sid.c:gid_to_sid(1362)
  WARNING: Winbindd not running, mapping ids with legacy code
[2007/05/18 01:26:20, 2] auth/auth.c:check_ntlm_password(309)
  check_ntlm_password:  authentication for user [IMACAT] -> [IMACAT] -> [imacat] succeeded

    Please tell me if you need any more information.  Thank you.
Comment 1 Björn Jacke 2014-07-29 13:50:16 UTC

*** This bug has been marked as a duplicate of bug 1920 ***