Bug 4571 - Samba 4 Does not support resolution of ipv6-literal.net names
Samba 4 Does not support resolution of ipv6-literal.net names
Status: RESOLVED DUPLICATE of bug 4549
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.25
Other All
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 09:47 UTC by David Holder
Modified: 2013-07-17 19:41 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Holder 2007-04-28 09:47:25 UTC
+++ This bug was initially created as a clone of Bug #4549 +++

The ipv6-literal.net domain is used by Vista and Longhorn to allow for the entry of IPv6 addresses into UNCs rather than host names. Any domain name in this domain is not passed to DNS but is resolved by taking the host portion and converting it into an IPv6 address.
For example:
3000:0:20::1 would be represented by 3000-0-20--1.ipv6-literal.net.
The Samba resolver needs to be modified to support this behaviour.
Let me know if you need any more info or if I can help with testing.
Comment 1 Björn Jacke 2013-07-17 19:41:46 UTC

*** This bug has been marked as a duplicate of bug 4549 ***