Bug 4549 - Feature request: Samba 4 should support resolution of ipv6-literal.net names
Feature request: Samba 4 should support resolution of ipv6-literal.net names
Status: RESOLVED WONTFIX
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
Other All
: P3 enhancement
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
: 4571 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-25 06:45 UTC by David Holder
Modified: 2013-07-18 08:50 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Holder 2007-04-25 06:45:53 UTC
The ipv6-literal.net domain is used by Vista and Longhorn to allow for the entry of IPv6 addresses into UNCs rather than host names. Any domain name in this domain is not passed to DNS but is resolved by taking the host portion and converting it into an IPv6 address.
For example:
3000:0:20::1 would be represented by 3000-0-20--1.ipv6-literal.net.
The Samba resolver needs to be modified to support this behaviour.
Let me know if you need any more info or if I can help with testing.
Comment 1 Andrew Bartlett 2007-07-16 23:32:47 UTC
Shouldn't this be in the (g)libc resolver?
Comment 2 David Holder 2007-07-17 04:13:25 UTC
I don't think so. Here are my reasons:
1) It isn't a published standard so putting in the resolver is probably a bad idea.
2) The namespace is owned by Microsoft.
Since it is a Microsoft specific solution that is not yet standardised. I think it is more appropriate that Samba should deal with this from a interoperability perspective.
Comment 3 David Holder 2007-09-28 11:42:18 UTC
One thing I didn't mention before is that you can also encode the interface identifier in the ipv6-literal.net address. This is useful for link local addresses. For example

fe80::10%4 can be written as the UNC or domain name fe80--10s4.ipv6-literal.net
Comment 4 Jelmer Vernooij 2008-01-06 21:17:56 UTC
I think we should use this only in the places where we actually use UNC names, not in the regular resolver. This demonstrates we need a generic UNC parser, which we don't appear to have at the moment.
Comment 5 Matthias Dieter Wallnöfer 2008-09-12 05:09:03 UTC
Marking as "Feature request"
Comment 6 Björn Jacke 2013-07-17 19:41:46 UTC
*** Bug 4571 has been marked as a duplicate of this bug. ***
Comment 7 Björn Jacke 2013-07-17 19:45:54 UTC
I don't see where Samba need this actually. Can you give a concrete example, where *samba* needs to handle ipv6-literal.net names? Looks more like a client only issue. *maybe* cifs vfs and friends might be interested in it, but even there I don't see a real need for it.
Comment 8 David Holder 2013-07-18 08:39:18 UTC
(In reply to comment #7)
> I don't see where Samba need this actually. Can you give a concrete example,
> where *samba* needs to handle ipv6-literal.net names? Looks more like a client
> only issue. *maybe* cifs vfs and friends might be interested in it, but even
> there I don't see a real need for it.

Agreed. This has been addressed by an NSS module written by Simo. This bug can be closed.
Comment 9 Björn Jacke 2013-07-18 08:50:48 UTC
ah great, didn't know that. Here's the link:

http://www.samba.org/~idra/code/nss-ipv6literal/