Bug 4462 - Argument of type "struct winbindd_request *" is incompatible with parameter of type "int".
Argument of type "struct winbindd_request *" is incompatible with parameter o...
Status: RESOLVED DUPLICATE of bug 4460
Product: Samba 3.0
Classification: Unclassified
Component: winbind
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2007-03-23 16:23 UTC by Joerg Behrens
Modified: 2007-03-23 16:30 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Joerg Behrens 2007-03-23 16:23:49 UTC
On my IRIX 6.5.30 plattform ând the latest mips cc 7.4.4 compiler i get the following error during compilation of samba 3.0.25pre2.

cc-1164 c99: ERROR File = nsswitch/winbind_nss_irix.c, Line = 457
  Argument of type "struct winbindd_request *" is incompatible with parameter of
          type "int".

        status = winbindd_send_request((int)rq->f_cmd_data,request,0);

1 error detected in the compilation of "nsswitch/winbind_nss_irix.c".

At the end i also get multible messages like this one:
Linking libmsrpc non-shared library bin/libmsrpc.a
(null): WARNING 1  : Unknown option: Wl,-rpath (ignored).
(null): WARNING 1  : Unknown option: Wl,/usr/nekoware/lib (ignored).

export CC=c99
export CFLAGS='-O3 -mips4 -I/usr/nekoware/include -OPT:Olimit=0:roundoff=3  -TARG:platform=IP27:proc=r10000'
export CPPFLAGS='-I/usr/nekoware/include'
export CXX=CC
export F77=f77
export LDFLAGS="-L/usr/nekoware/lib -Wl,-rpath -Wl,/usr/nekoware/lib"
export PKG_CONFIG=/usr/nekoware/bin/pkg-config
export PKG_CONFIG_PATH='/usr/nekoware/lib/pkgconfig'
export PKG_CONFIG_LIBDIR='/usr/nekoware/lib'
export LD_LIBRARY_PATH='/usr/nekoware/lib'
export LD_LIBRARYN32_PATH='/usr/nekoware/lib'
export LD_LIBRARY64_PATH='/usr/nekoware/lib64'
export GNOME2_DIR='/usr/nekoware'
export GNUMAKE='/usr/nekoware/bin/make'
export PATH=/usr/nekoware/bin:$PATH

./configure --with-python=/usr/nekoware/bin/python --with-winbind --with-acl-support --with-libsmbclient --with-sys-quotas --with-quotas --with-ldap=/usr/nekoware --with-smbwrapper --with-libiconv=/usr/nekoware --with-readline=/usr/nekoware --enable-cups --with-expsam=xml  --with-configdir=/usr/nekoware-build/etc --with-logfilebase=/usr/nekoware-build/var/log  --with-krb5=/usr/nekoware --prefix=/usr/nekoware-build

gmake -j30

Comment 1 Gerald (Jerry) Carter 2007-03-23 16:30:03 UTC
Already fixed in the SAMBA_3_0_25 tree.  See BUG 4460 for tha patch.

*** This bug has been marked as a duplicate of 4460 ***