Bug 4460 - error in winbind_nss_irix.c
error in winbind_nss_irix.c
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.25
SGI IRIX
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 4462 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-22 16:48 UTC by g.fischer@ah-online.com
Modified: 2007-03-23 16:30 UTC (History)
1 user (show)

See Also:


Attachments
Proposed patch (550 bytes, patch)
2007-03-22 17:02 UTC, Volker Lendecke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description g.fischer@ah-online.com 2007-03-22 16:48:32 UTC
samba 3.0.25pre2, irix 6.5.30, mipspro 7.4.x
----------

cc-1164 c99: ERROR File = nsswitch/winbind_nss_irix.c, Line = 457
  Argument of type "struct winbindd_request *" is incompatible with parameter of
          type "int".

        status = winbindd_send_request((int)rq->f_cmd_data,request,0);
                                                           ^
Comment 1 Volker Lendecke 2007-03-22 17:02:41 UTC
Created attachment 2344 [details]
Proposed patch

Can you try the attached patch and close the bug if it works for you?

Thanks,

Volker
Comment 2 g.fischer@ah-online.com 2007-03-22 22:54:20 UTC
works perfectly!
much thanks!!
Comment 3 Gerald (Jerry) Carter 2007-03-23 16:30:03 UTC
*** Bug 4462 has been marked as a duplicate of this bug. ***