Bug 4446 - Print queues not emptying
Print queues not emptying
Product: Samba 3.0
Classification: Unclassified
Component: Printing
x86 Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2007-03-13 09:51 UTC by Lutieri G. B.
Modified: 2008-07-25 12:07 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Lutieri G. B. 2007-03-13 09:51:37 UTC
+++ This bug was initially created as a clone of Bug #2220 +++

I'm having this problem under samba 3.0.24 running on FC5 x86.  Some printers, not all, show jobs in the Windows print queue.  The jobs show in Cups as completed  and are not in the Samba print spool at all. I've installed samba via yum. I run: rm -f /var/log/spool/samba/c* but don't solve the problem.

[root@ps ~]# smbd -b
Build environment:
   Built by:    brewbuilder@hs20-bc1-7.build.redhat.com
   Built on:    Wed Feb  7 23:52:44 EST 2007
   Built using: gcc
   Build host:  Linux hs20-bc1-7.build.redhat.com 2.6.9-34.ELsmp #1 SMP Fri Feb 24 16:56:28 EST 2006 i686 i686 i386 GNU/Linux
   SRCDIR:      /builddir/build/BUILD/samba-3.0.24/source
   BUILDDIR:    /builddir/build/BUILD/samba-3.0.24/source

Comment 1 josh 2008-05-27 13:16:37 UTC
I have the same problem.  Printer queue in windows fills up.  If I delete the tdb file in /var/lib/samba/printing then the queue is emptied until I print again.

Comment 2 josh 2008-05-27 13:32:05 UTC
I should have mentioned that my version is 
Version 3.2.0pre3-10.fc10

Comment 3 Alberto 2008-07-25 09:04:53 UTC
See also this post:


Best Regards
Comment 4 Karolin Seeger 2008-07-25 09:11:44 UTC
This one is fixed in 3.0.31 and will be fixed in 3.2.1.
A patch for 3.2.0 can be found at https://bugzilla.samba.org/show_bug.cgi?id=5635.

Please re-try with 3.0.31 and re-open the bug report if it is still an issue for you.

Thanks for the bug report!
Comment 5 Alberto 2008-07-25 12:07:18 UTC
I have tried the 3.0.31/3.0.28/3.0.26a versions compiled in opensuse build service and they work perfectly.