Bug 4335 - renaming a user ->loss of group memberships in ldap
Summary: renaming a user ->loss of group memberships in ldap
Status: RESOLVED DUPLICATE of bug 6353
Alias: None
Product: Samba 3.4
Classification: Unclassified
Component: User & Group Accounts (show other bugs)
Version: unspecified
Hardware: Other Linux
: P3 normal
Target Milestone: ---
Assignee: Volker Lendecke
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on: 6353
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-11 07:52 UTC by Björn Jacke
Modified: 2009-05-14 14:41 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2007-01-11 07:52:43 UTC
when a domain user from ldap is being renamed (hyena can do that for examplevery easy) the user's groupmemberships are lost becuase the memberUid attributes of the user's groups are not modified
Comment 1 Björn Jacke 2007-01-11 07:57:18 UTC
on the other hand this should maybe be one of the things the rename user script has to take care of, too.
Comment 2 Gerald (Jerry) Carter 2007-01-17 07:03:54 UTC
I really think this is outside of the scope of Samba.  If you rename 
the Unix account, you are responsible for responsible for renaming 
the entries in the groups as well. So yes, I would agree that this
should be done by the defined "rename user script".
Comment 3 Volker Lendecke 2007-01-17 07:07:54 UTC
Now it's me who re-opens a bug :-).

Jerry, you're right that this belongs to the scripts, but we now have ldapsam:editposix. There we need to fix it.

Volker
Comment 4 Björn Jacke 2009-05-14 14:41:42 UTC

*** This bug has been marked as a duplicate of bug 6353 ***