Bug 4130 - Does not delete partial files upon completion of transfer
Does not delete partial files upon completion of transfer
Status: RESOLVED DUPLICATE of bug 4132
Product: rsync
Classification: Unclassified
Component: core
2.6.8
Other Windows XP
: P3 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 19:13 UTC by mugi@pinesalad.net
Modified: 2006-09-28 19:19 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mugi@pinesalad.net 2006-09-28 19:13:33 UTC
Using any partial options (-P, --partial, --partial-dir) an interrupted rsync does create a partial file, however upon resuming and completion of the transfer the partial file is not removed.

Steps to reproduce:

1. working and verified rsync setup between two systems

2. run rsync with a somewhat large file in the source dir so you have a chance to interrupt it, use one of the partial options

Here's my example with a partial and temp directory set in the user (xfer) that is running the rsync job:

rsync -av --partial-dir=~xfer/partial --temp-dir=~xfer/tmp /xfer/outbox/* remoteserver:/xfer/inbox/

I'm putting a 200MB+ file in /xfer/outbox

3. Interrupt rsync with a Ctrl-C

4. Verify partial file is created on the remoteserver (in my example, look in ~xfer/partial directory on the remote server)

5. Run the same rsync command to let it continue/resume

6. Upon completion of the job, look on the remoteserver and you will see the partial file still exists (again, in my example the ~xfer/partial directory on the remote server).


I have verified the file remains with any of the partial options and using directories outside of the rsync tree that is being copied/updated.

2.6.8 source compiled on AIX 5.3
Comment 1 mugi@pinesalad.net 2006-09-28 19:19:23 UTC

*** This bug has been marked as a duplicate of 4132 ***