Bug 404 - smbcacls doesn't change ownership/group?
smbcacls doesn't change ownership/group?
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0preX
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 2076 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-04 08:53 UTC by Waider
Modified: 2005-08-24 10:28 UTC (History)
1 user (show)

See Also:


Attachments
allow owner and group-entries to be set with -S or -M (693 bytes, patch)
2004-11-22 18:07 UTC, Guenther Deschner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Waider 2003-09-04 08:53:37 UTC
smbcacls appears to be disregarding my attempts to change the OWNER and GROUP acls.

[root@workst1 c_drive]# smbcacls -A /root/cred //workst1/c\$ BOOT.BAK -M
OWNER:Admin -M GROUP:Domain\ Admins -S ACL:\\Everyone:ALLOWED/3/FULL
[root@workst1 c_drive]# smbcacls -A /root/cred //workst1/c\$ BOOT.BAK
REVISION:1
OWNER:WORKST1\root
GROUP:DOMAIN\Domain Users
ACL:WORKST1\root:ALLOWED/0/FULL
ACL:DOMAIN\Domain Users:ALLOWED/0/FULL
ACL:\Everyone:ALLOWED/0/FULL
Comment 1 Guenther Deschner 2004-11-22 18:06:34 UTC
*** Bug 2076 has been marked as a duplicate of this bug. ***
Comment 2 Guenther Deschner 2004-11-22 18:07:11 UTC
Created attachment 804 [details]
allow owner and group-entries to be set with -S or -M
Comment 3 Guenther Deschner 2004-11-22 18:07:39 UTC
Fixed in subversion. Thanks for reporting.
Comment 4 Gerald (Jerry) Carter 2005-02-07 09:06:17 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:28:03 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.