Bug 4020 - Encoding of ru_RU.cp1251is not displayed correctly if patch rhn 157208 is applied
Encoding of ru_RU.cp1251is not displayed correctly if patch rhn 157208 is app...
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: smbmount (unmaintained)
3.0.10
Other Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
https://bugzilla.redhat.com/bugzilla/...
:
: 4019 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-16 01:42 UTC by Vasiliy Kotikov
Modified: 2006-08-21 01:51 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vasiliy Kotikov 2006-08-16 01:42:09 UTC
Mounting on RHEL4 a M$ W2K3 share.

Locale is set to en_US

[root@uni018 ~]# mount -t smbfs -o
username=root,password=********,iocharset=cp1251,codepage=cp866
//uni022.mstuca.ru/Programs /mnt/smb && cp /mnt/smb/*.txt /data/ && umount /mnt/smb

[root@uni018 ~]# ls /data
INF.txt  ????????.txt  ????????.txt

Setting locale to display in cp1251

[root@uni018 ~]# export LC_ALL=ru_RU.CP1251
[root@uni018 ~]# ls -Al /data
итого 8
-rwxr-xr-x  1 root root   0 Авг 15 23:27 INF.txt
-rwxr-xr-x  1 root root 263 Авг 15 23:27 ‰Ќ€ЊЂЌ€….txt
-rwxr-xr-x  1 root root 263 Авг 15 22:58 ‚Ќ€ЊЂЌ€….txt
[root@uni018 ~]#


Setting putty to use CP866

[root@uni018 ~]# ls -Al /data
шЄюую 8
-rwxr-xr-x  1 root root   0 └ту 15 23:27 INF.txt
-rwxr-xr-x  1 root root 263 └ту 15 23:27 ЙНИМАНИЕ.txt
-rwxr-xr-x  1 root root 263 └ту 15 22:58 ВНИМАНИЕ.txt
[root@uni018 ~]#

Now names of files are read ok, but other data such as date's month (Авг), total
 8(итого 8) are displayed incorrectly.

maybe I've missed something and I should mount in another way??? But without
this patch encoding cp1251 works fine...
Comment 1 Gerald (Jerry) Carter 2006-08-16 09:54:32 UTC
*** Bug 4019 has been marked as a duplicate of this bug. ***
Comment 2 Gerald (Jerry) Carter 2006-08-16 09:55:16 UTC
smbfs is not out code.  You'll have to get RedHat to fix this
or possibly try the cifs fs kernel module instead.
Comment 3 Vasiliy Kotikov 2006-08-17 06:32:46 UTC
Please, explain what do you mean "possibly try the cifs fs kernel module instead"?

ThanX
Comment 4 Gerald (Jerry) Carter 2006-08-17 08:17:01 UTC
See http://linux-cifs.samba.org/
Comment 5 Vasiliy Kotikov 2006-08-21 01:51:07 UTC
ThanX alot :-)