Bug 4019 - Encoding of ru_RU.cp1251is not displayed correctly if patch rhn 157208 is applied
Encoding of ru_RU.cp1251is not displayed correctly if patch rhn 157208 is app...
Status: RESOLVED DUPLICATE of bug 4020
Product: Samba 3.0
Classification: Unclassified
Component: smbmount (unmaintained)
3.0.10
Other Windows XP
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
https://bugzilla.redhat.com/bugzilla/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-16 01:41 UTC by Vasiliy Kotikov
Modified: 2006-08-16 09:54 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vasiliy Kotikov 2006-08-16 01:41:52 UTC
Mounting on RHEL4 a M$ W2K3 share.

Locale is set to en_US

[root@uni018 ~]# mount -t smbfs -o
username=root,password=********,iocharset=cp1251,codepage=cp866
//uni022.mstuca.ru/Programs /mnt/smb && cp /mnt/smb/*.txt /data/ && umount /mnt/smb

[root@uni018 ~]# ls /data
INF.txt  ????????.txt  ????????.txt

Setting locale to display in cp1251

[root@uni018 ~]# export LC_ALL=ru_RU.CP1251
[root@uni018 ~]# ls -Al /data
итого 8
-rwxr-xr-x  1 root root   0 Авг 15 23:27 INF.txt
-rwxr-xr-x  1 root root 263 Авг 15 23:27 ‰Ќ€ЊЂЌ€….txt
-rwxr-xr-x  1 root root 263 Авг 15 22:58 ‚Ќ€ЊЂЌ€….txt
[root@uni018 ~]#


Setting putty to use CP866

[root@uni018 ~]# ls -Al /data
шЄюую 8
-rwxr-xr-x  1 root root   0 └ту 15 23:27 INF.txt
-rwxr-xr-x  1 root root 263 └ту 15 23:27 ЙНИМАНИЕ.txt
-rwxr-xr-x  1 root root 263 └ту 15 22:58 ВНИМАНИЕ.txt
[root@uni018 ~]#

Now names of files are read ok, but other data such as date's month (Авг), total
 8(итого 8) are displayed incorrectly.

maybe I've missed something and I should mount in another way??? But without
this patch encoding cp1251 works fine...
Comment 1 Gerald (Jerry) Carter 2006-08-16 09:54:32 UTC

*** This bug has been marked as a duplicate of 4020 ***