Bug 39 - -W option ignoring workgroup name
-W option ignoring workgroup name
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.0preX
Other other
: P1 major
: 3.0.0rc2
Assigned To: Gerald (Jerry) Carter
:
: 157 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-28 14:48 UTC by Gerald (Jerry) Carter
Modified: 2005-08-24 10:22 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald (Jerry) Carter 2003-04-28 14:48:36 UTC
Both 

  smbclient //samba1/public -U Administrator%bleaK.er -W Y2K -p 139
  smbclient //samba1/public -U Administrator%bleaK.er -W COLOR -p 139

result in the SMBsessetup&X request containing the 
domain name GLASS (from smb.conf)
Comment 1 Tim Potter 2003-04-28 16:59:09 UTC
Fixed in 3.0 and HEAD.

The client wasn't using the value of the workgroup stored by the common popt
handling code for the -W option.

Current bugzilla permissions prevent me from taking and closing the bug though.
Comment 2 Tim Potter 2003-04-28 17:05:53 UTC
The same bug exists for rpcclient too.

Also fixed in 3.0 and HEAD.
Comment 3 Jelmer Vernooij 2003-04-28 20:11:58 UTC
Your fix breaks the '-s' switch, because the popt common stuff sets 
dyn_CONFIGFILE and you are now using dyn_CONFIGFILE before it can be set 
by popt.  
Comment 4 Tim Potter 2003-04-29 09:17:45 UTC
I broke -s fixing -W.  A fair trade I think.  (-:

Jelmer has some ideas for fixing some of the mess so I'm reassigning it to him.
Comment 5 Jelmer Vernooij 2003-06-17 04:30:19 UTC
*** Bug 157 has been marked as a duplicate of this bug. ***
Comment 6 Gerald (Jerry) Carter 2003-08-25 10:06:40 UTC
This is still broken in the latest SAMBA_3_0 cvs tree.
Comment 7 Gerald (Jerry) Carter 2003-08-25 10:54:58 UTC
Make sure we save the -W value and restore it 
after lp_load().
Comment 8 Gerald (Jerry) Carter 2005-02-07 07:54:29 UTC
originally reported against 3.0alpha23.  Bugzilla spring cleaning.
Comment 9 Gerald (Jerry) Carter 2005-08-24 10:22:22 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.