Bug 157 - smbclient don't handle that smb.conf is placed in a different directory even if -s is supplied
smbclient don't handle that smb.conf is placed in a different directory even ...
Status: RESOLVED DUPLICATE of bug 39
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.0preX
All Solaris
: P2 normal
: none
Assigned To: Jelmer Vernooij
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-12 07:15 UTC by Patrik Gustavsson
Modified: 2005-11-14 09:25 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrik Gustavsson 2003-06-12 07:15:30 UTC
smbclient dont't handle the -s option.

/usr/local/samba/bin/smbclient '\\SAMBA\patrikg' -s
/global/mnt1/SAMBA/lib/smb.conf -U patrikg

generate

params.c:OpenConfFile() - Unable to open configuration file
"/usr/local/samba/lib/smb.conf":
        No such file or directory
/usr/local/samba/bin/smbclient: Can't load /usr/local/samba/lib/smb.conf - run
testparm to debug it
Comment 1 Tim Potter 2003-06-12 21:47:32 UTC
Aargh - another one of these popt/lp_load() ordering problems.

Jelmer can you take a look at this?
Comment 2 Jelmer Vernooij 2003-06-17 04:30:15 UTC

*** This bug has been marked as a duplicate of 39 ***
Comment 3 Gerald (Jerry) Carter 2005-02-07 08:39:10 UTC
originally reported against 3.0.0beta1.  CLeaning out 
non-production release versions.
Comment 4 Gerald (Jerry) Carter 2005-11-14 09:25:29 UTC
database cleanup