Bug 378 - smbd crash on client disconnect (mee too)
smbd crash on client disconnect (mee too)
Status: RESOLVED DUPLICATE of bug 376
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0preX
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-31 14:44 UTC by Kenneth Edlund
Modified: 2005-11-14 09:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Edlund 2003-08-31 14:44:56 UTC
I see the same thing in my stacktraces as Joachim Haga.

Linux Slackware 9.0


[2003/08/31 22:40:27, 1] smbd/service.c:make_connection_snum(692)
  wxp (192.168.1.247) connect to service store initially as user kenta
(uid=1000, gid=100) (pid 373)
[2003/08/31 22:40:22, 1] smbd/service.c:make_connection_snum(692)
  wxp (192.168.1.247) connect to service gemensam initially as user kenta
(uid=1000, gid=100) (pid 373)
[2003/08/31 22:40:28, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2003/08/31 22:40:28, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 373 (3.0.0rc2)
  Please read the appendix Bugs of the Samba HOWTO collection
[2003/08/31 22:40:28, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2003/08/31 22:40:28, 0] lib/util.c:smb_panic(1462)
  PANIC: internal error
[2003/08/31 22:40:28, 0] lib/util.c:smb_panic(1469)
  BACKTRACE: 16 stack frames:
   #0 /usr/local/samba/bin/smbd(smb_panic+0x1ea) [0x81ec141]
   #1 /usr/local/samba/bin/smbd [0x81d7971]
   #2 /usr/local/samba/bin/smbd [0x81d79d5]
   #3 /lib/libc.so.6 [0x400a3b48]
   #4 /lib/libc.so.6 [0x400f0533]
   #5 /lib/libc.so.6(malloc+0x95) [0x400ef6b5]
   #6 /usr/local/samba/bin/smbd(Realloc+0x9c) [0x81eb44c]
   #7 /usr/local/samba/bin/smbd [0x80b8a16]
   #8 /usr/local/samba/bin/smbd(reply_trans2+0xa91) [0x80bedc3]
   #9 /usr/local/samba/bin/smbd [0x80d6777]
   #10 /usr/local/samba/bin/smbd [0x80d684d]
   #11 /usr/local/samba/bin/smbd(process_smb+0x217) [0x80d6be6]
   #12 /usr/local/samba/bin/smbd(smbd_process+0x200) [0x80d7998]
   #13 /usr/local/samba/bin/smbd(main+0x851) [0x8251aef]
   #14 /lib/libc.so.6(__libc_start_main+0xa4) [0x4008fbb4]
   #15 /usr/local/samba/bin/smbd(yp_get_default_domain+0x7d) [0x8071821]
[2003/08/31 22:40:30, 1] smbd/service.c:make_connection_snum(692)
  wxp (192.168.1.247) connect to service gemensam initially as user kenta
(uid=1000, gid=100) (pid 374)
[2003/08/31 22:40:31, 1] smbd/service.c:make_connection_snum(692)
  wxp (192.168.1.247) connect to service kenta initially as user kenta
(uid=1000, gid=100) (pid 374)
[2003/08/31 22:40:39, 1] smbd/service.c:make_connection_snum(692)
  wxp (192.168.1.247) connect to service program initially as user kenta
(uid=1000, gid=100) (pid 374)
[2003/08/31 22:57:34, 0] rpc_server/srv_util.c:get_domain_user_groups(371)
  get_domain_user_groups: primary gid of user [kenta] is not a Domain group !
  get_domain_user_groups: You should fix it, NT doesn't like that
[2003/08/31 22:57:38, 1] smbd/service.c:close_cnum(874)
  wxp (192.168.1.247) closed connection to service kenta
Comment 1 Tim Potter 2003-09-01 00:17:02 UTC

*** This bug has been marked as a duplicate of 376 ***
Comment 2 Gerald (Jerry) Carter 2005-02-07 09:05:49 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 3 Gerald (Jerry) Carter 2005-11-14 09:30:35 UTC
database cleanup