Bug 376 - smbd crash on client disconnect
smbd crash on client disconnect
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0preX
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
: 378 (view as bug list)
Depends on:
Blocks: 807
  Show dependency treegraph
 
Reported: 2003-08-30 07:39 UTC by Joachim Haga
Modified: 2005-11-14 09:28 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joachim Haga 2003-08-30 07:39:25 UTC
I got this stacktrace from smbd on smbclient disconnect. Since the client
disconnects there is not much harm in it but here it is for reference.

For me this happens in about 1 out of 3 cases. Let me know if there are problems
reproducing it.


[2003/08/30 16:23:37, 1] smbd/service.c:close_cnum(874)
  pep (127.0.0.1) closed connection to service musikk
[2003/08/30 16:23:37, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2003/08/30 16:23:37, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 27821 (3.0.0rc2)
  Please read the appendix Bugs of the Samba HOWTO collection
[2003/08/30 16:23:37, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2003/08/30 16:23:37, 0] lib/util.c:smb_panic(1452)
  smb_panic(): calling panic action [/usr/share/samba/panic-action 27821]
[2003/08/30 16:23:47, 0] lib/util.c:smb_panic(1460)
  smb_panic(): action returned status 0
[2003/08/30 16:23:47, 0] lib/util.c:smb_panic(1462)
  PANIC: internal error
[2003/08/30 16:23:47, 0] lib/util.c:smb_panic(1469)
  BACKTRACE: 14 stack frames:
   #0 /usr/local/samba/sbin/smbd(smb_panic+0xc9) [0x81749f1]
   #1 /usr/local/samba/sbin/smbd [0x816643a]
   #2 /lib/libc.so.6 [0x400a09d8]
   #3 /lib/libc.so.6 [0x400e3e80]
   #4 /lib/libc.so.6(malloc+0xa1) [0x400e3145]
   #5 /usr/local/samba/sbin/smbd [0x8182e49]
   #6 /usr/local/samba/sbin/smbd(tdb_fetch+0x7d) [0x8183e81]
   #7 /usr/local/samba/sbin/smbd(session_yield+0x71) [0x807c5f1]
   #8 /usr/local/samba/sbin/smbd(invalidate_vuid+0x52) [0x807eab2]
   #9 /usr/local/samba/sbin/smbd(invalidate_all_vuids+0x1f) [0x807ebff]
   #10 /usr/local/samba/sbin/smbd(exit_server+0x67) [0x81bba1b]
   #11 /usr/local/samba/sbin/smbd(main+0x41f) [0x81bc003]
   #12 /lib/libc.so.6(__libc_start_main+0xdd) [0x4008fa51]
   #13 /usr/local/samba/sbin/smbd(chroot+0x31) [0x807165d]
[2003/08/30 16:29:02, 1] smbd/service.c:make_connection_snum(692)
  pep (127.0.0.1) connect to service musikk initially as user musikk (uid=1000,
gid=1000) (pid 28222)
[2003/08/30 16:29:11, 1] smbd/service.c:close_cnum(874)
  pep (127.0.0.1) closed connection to service musikk
Comment 1 Joachim Haga 2003-08-30 07:48:30 UTC
Oops, should have been rc2
Comment 2 Tim Potter 2003-09-01 00:17:03 UTC
*** Bug 378 has been marked as a duplicate of this bug. ***
Comment 3 Gerald (Jerry) Carter 2003-12-07 22:20:43 UTC
is this still real in 3.0.1rc1?
Comment 4 Joachim Haga 2003-12-08 04:04:41 UTC
Unfortunately I don't have this setup anymore so I can't verify easily if the 
crash is still there. I can set it up again but not for a few weeks, have to
concentrate on my exams...
Comment 5 Gerald (Jerry) Carter 2003-12-08 06:04:07 UTC
ok.  Thanks.  I'll look into it some more since there are a 
couple of other crash bugs I'm working.  let me know if you 
find out any more information.
Comment 6 Gerald (Jerry) Carter 2004-01-14 13:01:26 UTC
marking as fixed since there have 

  (a) been several memory coprruption bugs fixed since 3.0.0
  (b) original test setup is no longer available
Comment 7 Gerald (Jerry) Carter 2005-02-07 09:05:45 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 8 Gerald (Jerry) Carter 2005-08-24 10:24:43 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 9 Gerald (Jerry) Carter 2005-11-14 09:28:37 UTC
database cleanup