Bug 3480 - Lots of repeated errors in samba log
Lots of repeated errors in samba log
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.20a
Other Windows XP
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 3481 3482 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 15:09 UTC by jason qian (e-mail address couldn't be found)
Modified: 2006-12-21 09:15 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jason qian (e-mail address couldn't be found) 2006-02-03 15:09:24 UTC
I find quite a lot of repeated errors in samba logs:

The first one is:
[2006/02/03 12:14:00, 2] auth/auth.c:check_ntlm_password(317)
  check_ntlm_password:  Authentication for user [nobody] -> [nobody] FAILED with error NT_STATUS_WRONG_PASSWORD

The second one is:
[2006/02/03 12:14:00, 0] lib/util_sock.c:get_peer_addr(1340)
  getpeername failed. Error was Transport endpoint is not connected
[2006/02/03 12:14:00, 0] lib/util_sock.c:write_data(554)
  write_data: write failure in writing to client 85.138.152.42. Error Connection reset by peer
[2006/02/03 12:14:00, 0] lib/util_sock.c:send_smb(880)
  Error writing 4 bytes to client. -1. (Connection reset by peer)

Are these errors are normal?
Comment 1 Gerald (Jerry) Carter 2006-02-03 15:32:21 UTC
*** Bug 3482 has been marked as a duplicate of this bug. ***
Comment 2 Gerald (Jerry) Carter 2006-02-03 15:32:28 UTC
*** Bug 3481 has been marked as a duplicate of this bug. ***
Comment 3 Mark Condic 2006-03-10 23:01:49 UTC
From a small peer to peer network of Win98SE, WinXPsp2 and SuSE 10.0

Let me know if I can provide higher level trace.

  smbd version 3.0.21c-3.1.4-SUSE-SL10.0 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2006
[2006/03/10 20:41:46, 0] lib/util_sock.c:write_data(557)
  write_data: write failure in writing to client 192.168.1.151. Error Connection reset by peer
[2006/03/10 20:41:46, 0] lib/util_sock.c:send_smb(765)
  Error writing 4 bytes to client. -1. (Connection reset by peer)
[2006/03/10 21:13:46, 0] lib/util_sock.c:get_peer_addr(1225)
  getpeername failed. Error was Transport endpoint is not connected
[2006/03/10 21:13:46, 0] lib/util_sock.c:write_data(557)
  write_data: write failure in writing to client 192.168.1.151. Error Connection reset by peer
[2006/03/10 21:13:46, 0] lib/util_sock.c:send_smb(765)
  Error writing 4 bytes to client. -1. (Connection reset by peer)
Comment 4 Gerald (Jerry) Carter 2006-03-10 23:29:52 UTC
These appear as normal errors to me.  Search the samba ml 
for previous discussions about this.
Comment 5 Björn Jacke 2006-12-21 09:15:59 UTC
this one might be caused by keep alive packages samba sends out on port 445. Windows doesn't like keep alive smb packages on 445 and quits the connection instead. Try setting keep alive = 0.