Bug 3315 - smbfs: smbmount hangs (fork / signal deadlock)
smbfs: smbmount hangs (fork / signal deadlock)
Status: RESOLVED DUPLICATE of bug 1920
Product: Samba 3.0
Classification: Unclassified
Component: smbmount (unmaintained)
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-12-12 00:22 UTC by Christian Perrier
Modified: 2014-07-29 13:53 UTC (History)
1 user (show)

See Also:

Proposed patch for #3315 (untested by bug submitter) (1.14 KB, patch)
2005-12-12 00:24 UTC, Christian Perrier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Perrier 2005-12-12 00:22:02 UTC
The ful bug log in in Debian bug #305210 (see URL).

Summary of the bug reporter explanations:

Recently, smbmount started to just hang after successfully mounting a
share. Google showed that others have reported this behaviour a long
time ago, with other versions of samba. 

One interesting hit that actually included a patch was

The described behaviour matches the facts I was able to observe with

Guess what, the patch applied (with some minor tweaking) to samba
3.0.11, and it actually solved my problem. So it looks like this
long-standing problem has not been fixed yet, and may have been
triggered by a recent kernel update.

I adapted the sent patch for samba 3.0.20b source...This is what I will attach here.
Comment 1 Christian Perrier 2005-12-12 00:24:25 UTC
Created attachment 1611 [details]
Proposed patch for #3315 (untested by bug submitter)

This is the patch proposed by the original submitter in Debian, re-adapted for 3.0.20b sources
Comment 2 Björn Jacke 2014-07-29 13:53:30 UTC

*** This bug has been marked as a duplicate of bug 1920 ***