Bug 3217 - Wbinfo unable to get user-domgroups for a group on OpenSuSE 10
Summary: Wbinfo unable to get user-domgroups for a group on OpenSuSE 10
Status: RESOLVED DUPLICATE of bug 3201
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: winbind (show other bugs)
Version: 3.0.20a
Hardware: All Linux
: P3 normal
Target Milestone: none
Assignee: Samba Bugzilla Account
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-26 10:04 UTC by Brian Moran
Modified: 2005-10-27 00:06 UTC (History)
0 users

See Also:


Attachments
Logs of Winbind Present (162.68 KB, application/octet-stream)
2005-10-26 10:07 UTC, Brian Moran
no flags Details
Ethereal dump of winbind and all other traffic (91.83 KB, application/octet-stream)
2005-10-26 10:10 UTC, Brian Moran
no flags Details
Proposed patch (745 bytes, patch)
2005-10-27 00:06 UTC, Volker Lendecke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Moran 2005-10-26 10:04:39 UTC
On OpenSuSE 10, wbinfo fails to get the user-domgroups of groups. Used on 
RHEL4, SuSE 9.2, SuSE 9.3, it works fine. 

In the past, we saw an issue with one of the higher optimization levels (O2)
causing this bug to manifest. Now it seems to occur at a lower optimization
level as well.

Attached are winbind logs, as well as ethereal dump.
Comment 1 Brian Moran 2005-10-26 10:07:57 UTC
Created attachment 1541 [details]
Logs of Winbind Present
Comment 2 Brian Moran 2005-10-26 10:10:04 UTC
Created attachment 1542 [details]
Ethereal dump of winbind and all other traffic
Comment 3 Gerald (Jerry) Carter 2005-10-26 10:44:35 UTC
pretty sure this is a dup.  Patch posted at http://www.samba.org/samba/patches/

*** This bug has been marked as a duplicate of 3201 ***
Comment 4 Volker Lendecke 2005-10-27 00:06:16 UTC
Created attachment 1546 [details]
Proposed patch

This is *so* weird. I'm 100% certain at one point this worked. I now remember
what 54b is: Failure to correctly fill in the dcname field of the getdc
request.

Could you try the attached patch?

Thanks,

Volker