Bug 3201 - Winbind does'nt show users groups
Winbind does'nt show users groups
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.20b
x86 Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
: 3217 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-22 08:58 UTC by Sergio Roberto Claser
Modified: 2005-10-26 10:44 UTC (History)
1 user (show)

See Also:


Attachments
zero winbind request structure (1.20 KB, patch)
2005-10-24 09:45 UTC, Gerald (Jerry) Carter
no flags Details
correct patch that actually compiles (566 bytes, patch)
2005-10-24 09:49 UTC, Gerald (Jerry) Carter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergio Roberto Claser 2005-10-22 08:58:39 UTC
The command 'wbinfo -r domain\user' does'nt show/get users groups. In version
3.0.20 works fine. The problem begins in version 3.0.20a.
Comment 1 Gerald (Jerry) Carter 2005-10-24 07:24:12 UTC
reproduced.  Seems to be linked to 

000000 net_io_r_getdcname
    0000 ptr_dcname: 00000000
    000004 smb_io_unistr2 - NULL dcname
    0004 status: NT code 0x0000054b
Error requesting DCname: NT_STATUS_UNSUCCESSFUL




:-(
Comment 2 Gerald (Jerry) Carter 2005-10-24 07:47:20 UTC
Jeremy,

I'm pretty sure this is caused by the recusion fix you put 
in for 3.0.20a  Sorry.  The wbinfo -r is never even writing
to the socket.....
Comment 3 Gerald (Jerry) Carter 2005-10-24 07:48:21 UTC
The problem appears to be that winbind_open_pipe_sock() is just 
returning -1 due to the recusing flag being set.
Comment 4 Guenther Deschner 2005-10-24 07:57:39 UTC
(In reply to comment #1)
> reproduced.  Seems to be linked to 
> 
> 000000 net_io_r_getdcname
>     0000 ptr_dcname: 00000000
>     000004 smb_io_unistr2 - NULL dcname
>     0004 status: NT code 0x0000054b
> Error requesting DCname: NT_STATUS_UNSUCCESSFUL
> 
> 
> 
> 
> :-(


Yes, I've seen this too: 
A getdcname reply of a getdcname request for your own host (that is beeing sent
to your DC).
Comment 5 Jeremy Allison 2005-10-24 08:47:15 UTC
Can you show me the backtrace when it's doing that ? I thought I'd caught all
possible uses of this.
Jeremy.
Comment 6 Gerald (Jerry) Carter 2005-10-24 09:20:14 UTC
backtrace:

#0  winbind_open_pipe_sock (recursing=2048) at wb_common.c:307
#1  0x0809b8d2 in write_sock (buffer=0xbfffea70, count=1832, recursing=2048) 
    at wb_common.c:351
#2  0x0809bd12 in winbindd_send_request (req_type=5, request=0xbfffea70) 
    at wb_common.c:544
#3  0x0809be4c in winbindd_request_response (req_type=5, request=0xbfffea70,
    response=0xbfffe550) at wb_common.c:599
#4  0x080593c0 in wbinfo_get_usergroups (user=0x811d920 "color+administrator") 
    at wbinfo.c:126
#5  0x0805b597 in main (argc=3, argv=0xbffff584) at wbinfo.c:1135
Comment 7 Gerald (Jerry) Carter 2005-10-24 09:45:30 UTC
Created attachment 1532 [details]
zero winbind request structure
Comment 8 Gerald (Jerry) Carter 2005-10-24 09:49:35 UTC
Created attachment 1533 [details]
correct patch that actually compiles
Comment 9 Gerald (Jerry) Carter 2005-10-24 09:52:53 UTC
Fixed.

# bin/wbinfo -r 'color+administrator'
60013
60022
60023
60024
60025
Comment 10 Sergio Roberto Claser 2005-10-24 15:52:03 UTC
OK, thanks.
Comment 11 Gerald (Jerry) Carter 2005-10-26 10:44:36 UTC
*** Bug 3217 has been marked as a duplicate of this bug. ***