Bug 318 - Invalid file name mapping
Invalid file name mapping
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0preX
All Windows 2000
: P2 normal
: none
Assigned To: Jeremy Allison
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-18 11:40 UTC by Mike Pakovic
Modified: 2005-11-14 09:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Pakovic 2003-08-18 11:40:03 UTC
When trying to open a file with Autocad 2000, smbd translates xxxxxx.dwg to be
xxxxx.dwk (xxx is the file path), and then declares that it cannot find
xxxxx.dwk.  The share the file is on is mounted readonly with user ppp having
write permission.  User ppp can open the file normally (the log.ppp shows that
the .dwg is not translated to .dwk).  Everyone else has a problem.  The
permissions are 0644 on the file in question.  I have level 6 logs about what is
happening, but I included an excerpt below.  Ignore the "MIKE" debugging stuff,
I added that to see if I could see what was happening.

Mike

[2003/08/18 14:08:01, 5] smbd/filename.c:unix_convert(114)
  unix_convert called on file "\S-3 Maintenance
Trainers\CAINS\Drawings\10102W769F.dwg"
[2003/08/18 14:08:01, 3] lib/util.c:unix_clean_name(580)
  unix_clean_name [/S-3 Maintenance Trainers/CAINS/Drawings/10102W769F.dwg]
[2003/08/18 14:08:01, 3] lib/util.c:unix_clean_name(580)
  unix_clean_name [S-3 Maintenance Trainers/CAINS/Drawings/10102W769F.dwg]
[2003/08/18 14:08:01, 3] smbd/trans2.c:call_trans2qfilepathinfo(1865)
  call_trans2qfilepathinfo S-3 Maintenance
Trainers/CAINS/Drawings/10102W769F.dwg (fnum = -1) level=1004 call=5 total_data=0
[2003/08/18 14:08:01, 5] smbd/trans2.c:call_trans2qfilepathinfo(1971)
  SMB_QFBI - create: Thu Jul 24 09:42:38 2003
   access: Mon Aug 18 14:08:01 2003
   write: Thu Jul 24 09:42:38 2003
   change: Thu Jul 24 09:42:38 2003
   mode: 80
[2003/08/18 14:08:01, 3] smbd/process.c:process_smb(890)
  Transaction 275 of length 190
[2003/08/18 14:08:01, 5] lib/util.c:show_msg(456)
[2003/08/18 14:08:01, 5] lib/util.c:show_msg(466)
  size=186
  smb_com=0x32
  smb_rcls=0
 smb_reh=0
  smb_err=0
  smb_flg=24
  smb_flg2=51207
  smb_tid=4
  smb_pid=304
  smb_uid=100
  smb_mid=52545
  smt_wct=15
  smb_vwv[ 0]=  118 (0x76)
  smb_vwv[ 1]=    0 (0x0)
  smb_vwv[ 2]=    2 (0x2)
  smb_vwv[ 3]=   40 (0x28)
  smb_vwv[ 4]=    0 (0x0)
  smb_vwv[ 5]=    0 (0x0)
  smb_vwv[ 6]=    0 (0x0)
  smb_vwv[ 7]=    0 (0x0)
  smb_vwv[ 8]=    0 (0x0)
  smb_vwv[ 9]=  118 (0x76)
  smb_vwv[10]=   68 (0x44)
  smb_vwv[11]=    0 (0x0)
  smb_vwv[12]=    0 (0x0)
  smb_vwv[13]=    1 (0x1)
   smb_vwv[14]=    5 (0x5)
  smb_bcc=121
[2003/08/18 14:08:01, 3] smbd/process.c:switch_message(685)
  switch message SMBtrans2 (pid 28581)
[2003/08/18 14:08:01, 4] smbd/uid.c:change_to_user(122)
  change_to_user: Skipping user change - already user
[2003/08/18 14:08:01, 3] smbd/trans2.c:call_trans2qfilepathinfo(1835)
  call_trans2qfilepathinfo: TRANSACT2_QPATHINFO: level = 1004
[2003/08/18 14:08:01, 3] smbd/trans2.c:call_trans2qfilepathinfo(1837)
  MIKE inbuf = "" "<90><95>4^H^A"
[2003/08/18 14:08:01, 3] smbd/trans2.c:call_trans2qfilepathinfo(1839)
  MIKE2 inbuf = "" "\S-3 Maintenance Trainers\CAINS\Drawings\10102W769F.dwk" 1024
[2003/08/18 14:08:01, 5] smbd/filename.c:unix_convert(114)
  unix_convert called on file "\S-3 Maintenance
Trainers\CAINS\Drawings\10102W769F.dwk"
[2003/08/18 14:08:01, 3] lib/util.c:unix_clean_name(580)
  unix_clean_name [/S-3 Maintenance Trainers/CAINS/Drawings/10102W769F.dwk]
[2003/08/18 14:08:01, 5] smbd/filename.c:unix_convert(188)
  unix_convert begin: name = S-3 Maintenance
Trainers/CAINS/Drawings/10102W769F.dwk, dirpath = S-3 Maintenance
Trainers/CAINS/Drawings, start = 10102W769F.dwk
[2003/08/18 14:08:01, 5] smbd/filename.c:unix_convert(323)
  New file 10102W769F.dwk
[2003/08/18 14:08:01, 3] lib/util.c:unix_clean_name(580)
  unix_clean_name [S-3 Maintenance Trainers/CAINS/Drawings/10102W769F.dwk]
[2003/08/18 14:08:01, 3] smbd/trans2.c:call_trans2qfilepathinfo(1856)
  call_trans2qfilepathinfo: SMB_VFS_STAT of S-3 Maintenance
Trainers/CAINS/Drawings/10102W769F.dwk failed (No such file or directory)
[2003/08/18 14:08:01, 3] smbd/error.c:error_packet(94)
  error string = No such file or directory
[2003/08/18 14:08:01, 3] smbd/error.c:error_packet(113)
  error packet at smbd/trans2.c(1728) cmd=50 (SMBtrans2)
NT_STATUS_OBJECT_NAME_NOT_FOUND
[2003/08/18 14:08:01, 5] lib/util.c:show_msg(456)
[2003/08/18 14:08:01, 5] lib/util.c:show_msg(466)
  size=35
Comment 1 Mike Pakovic 2003-08-18 12:23:30 UTC
Here's what may be some important info.  When the autocad2000 user selects the
file in the autocad open dialog, he is able to see a preview of the file
contents.  That works.  When he then hits "open" to open the file, that fails. 
It seems that since the user can preview the file, it is a least opened once,
but fails on the second attempt?  Just a thought.

Mike
Comment 2 Mike Pakovic 2003-08-19 15:50:47 UTC
Bug 325 is, I believe, a duplicate of the bug.  The file my user was trying to
open also had a "-" character in the directory path (S-3 Maintenance
Trainers/CAINS/Drawings/10102W769F.dwg)

Mike
Comment 3 Gerald (Jerry) Carter 2003-11-04 20:40:20 UTC
Jeremy, Can you look at this one and see if maybe it is 
related to a stat open?
Comment 4 Jeremy Allison 2003-11-06 12:33:13 UTC
The strange thing about this is that the incoming request has
a name ending in .DWK, not .DWG. I don't think this is Samba
doing anything to the name, it's what is coming in on the wire.
I would need to see ethereal capture traces to be sure. This
doesn't look like a smbd bug, but I'd need to know how it's
supposed to work against a W2K server.
Jeremy.
Comment 5 Gerald (Jerry) Carter 2004-03-18 08:06:50 UTC
No feedback in several months.  Also doesn't appear 
to be our fault.  Closing.
Comment 6 Gerald (Jerry) Carter 2005-02-07 09:06:27 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 7 Gerald (Jerry) Carter 2005-11-14 09:26:00 UTC
database cleanup