Bug 325 - Problem with some directories on a share.
Problem with some directories on a share.
Product: Samba 3.0
Classification: Unclassified
Component: File Services
All Linux
: P2 critical
: none
Assigned To: Gerald (Jerry) Carter
Depends on:
  Show dependency treegraph
Reported: 2003-08-19 13:12 UTC by Kurt Dillen
Modified: 2005-11-14 09:27 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Dillen 2003-08-19 13:12:15 UTC
I have on my SAMBA 3 PDC about 10 shares.

On one of them I have some sub-directories which contains the "-" symbol in 
their name.   I don't have problems as long as that subdirectory does not have 
extra sub-directories. 

I also tried to recreate the problem on an other share, and here I don't have 
the issue.  The strange part is that the problem is on only one share.  

I reinstalled the Beta3 and the problem does not excists in total.
Comment 1 Kurt Dillen 2003-08-19 13:13:29 UTC
If you need more information let me know what you need and which debug level 
to use for the log files and I will reproduce it.

Comment 2 Gerald (Jerry) Carter 2003-08-25 21:51:44 UTC
Jeremy,  Can you take a look at these when you get a chance? Thanks.
Comment 3 Gerald (Jerry) Carter 2003-08-27 13:05:17 UTC
RC2 will ship with this issue unresolved.  We'll put it on 
the plate for RC3 and hope to resolve it by then.
Comment 4 Kurt Dillen 2003-09-03 12:14:51 UTC
Looks like it is solved in RC2.  Because the problem only comes up in RC1 not 
Beta 3 and RC2

Can we keep this one onhold to follow up to see if it comes back in a later 
release ?

Comment 5 Gerald (Jerry) Carter 2003-10-01 09:52:06 UTC
Kurt, please let me know the outcome against 3.0.0 so 
we can close this one out (hopefully).
Comment 6 Kurt Dillen 2003-10-01 11:59:32 UTC
I did do several tests with different systems on Samba 3.0.0  

Everything is working fine.

Thank you guys for fixing the bug....  And keep up the good work.

So please put it to FIXED I don't have the permissions to do it ;-)

Comment 7 Gerald (Jerry) Carter 2003-10-01 13:02:09 UTC
reporter says fixed.  Closing it out.
Comment 8 Gerald (Jerry) Carter 2005-02-07 09:06:07 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 9 Gerald (Jerry) Carter 2005-08-24 10:17:32 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 10 Gerald (Jerry) Carter 2005-11-14 09:27:38 UTC
database cleanup