Bug 294 - WERR_UNKNOWN_PRINTER_DRIVER
WERR_UNKNOWN_PRINTER_DRIVER
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.0preX
All Linux
: P3 major
: 3.0.0rc2
Assigned To: Gerald (Jerry) Carter
:
: 295 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-12 18:51 UTC by Alexey Zilber
Modified: 2005-11-14 09:29 UTC (History)
0 users

See Also:


Attachments
All logs debug level 10 for cupsaddsmb command and rpcclient query (255.69 KB, application/zip)
2003-08-12 22:10 UTC, Alexey Zilber
no flags Details
My smb.conf file. (10.86 KB, text/plain)
2003-08-12 22:11 UTC, Alexey Zilber
no flags Details
smb.conf (11.02 KB, text/plain)
2003-08-13 18:27 UTC, Alexey Zilber
no flags Details
rpcclient -d 10 -U'root%secret' Printboy -c 'getdriver "Canon" 3' (75.19 KB, text/plain)
2003-08-13 23:34 UTC, Alexey Zilber
no flags Details
rpcclient -d 10 (75.15 KB, text/plain)
2003-08-15 17:16 UTC, Alexey Zilber
no flags Details
rpcclient -d 10 for Samba 3rc1 (86.65 KB, text/plain)
2003-08-18 05:49 UTC, Alexey Zilber
no flags Details
Win2k Event Log (344 bytes, application/octet-stream)
2003-08-19 20:50 UTC, Alexey Zilber
no flags Details
smbd and nmbd -d 10 logs (664.95 KB, application/zip)
2003-08-20 01:30 UTC, Alexey Zilber
no flags Details
Screenshot on win2k of the bug. (149.61 KB, image/jpeg)
2003-08-20 01:43 UTC, Alexey Zilber
no flags Details
My Canon PPD file generated by RH9/foomatic. (117.45 KB, application/octet-stream)
2003-08-20 20:04 UTC, Alexey Zilber
no flags Details
Some of the latest -d 10 logs for cvs. (754.89 KB, application/zip)
2003-08-21 02:32 UTC, Alexey Zilber
no flags Details
Newest Screenshot. (163.41 KB, image/jpeg)
2003-08-23 02:53 UTC, Alexey Zilber
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Zilber 2003-08-12 18:51:47 UTC
WERR_UNKNOWN_PRINTER_DRIVER after a good cupsaddsmb printer driver installation.
Also happens on prior versions of Samba.

Here's the whole output set with -d 3:

added interface ip=192.168.160.140
bcast=192.168.160.255 nmask=255.255.255.0
Connecting to host=printproc share=IPC$
Connecting to 127.0.0.1 at port 445
Doing spnego session setup (blob length=58)
got OID=1 3 6 1 4 1 311 2 2 10
got principal=NONE
Got challenge flags:
Got NTLMSSP neg_flags=0x20830205
NTLMSSP: Set final flags:
Got NTLMSSP neg_flags=0x20000205
lsa_io_sec_qos: length c does not match size 8

[Windows NT x86]
Printer Driver Info 3:
	Version: [2]
	Driver Name: [Canon]
	Architecture: [Windows NT x86]
	Driver Path:
[\\printproc\print$\W32X86\2\cupsdrvr.dll]
	Datafile: [\\printproc\print$\W32X86\2\Canon.ppd]
	Configfile: [\\printproc\print$\W32X86\2\cupsui.dll]
	Helpfile: [\\printproc\print$\W32X86\2\cups.hlp]


	Monitorname: []
	Defaultdatatype: [RAW]

result was WERR_UNKNOWN_PRINTER_DRIVER
Comment 1 Gerald (Jerry) Carter 2003-08-12 20:45:48 UTC
*** Bug 295 has been marked as a duplicate of this bug. ***
Comment 2 Tim Potter 2003-08-12 21:05:42 UTC
Alexey, is there any chance of a level 10 debug from the smbd that handles the
cupsaddsmb command?
Comment 3 Alexey Zilber 2003-08-12 22:10:21 UTC
Created attachment 71 [details]
All logs debug level 10 for cupsaddsmb command and rpcclient query

I stopped smb, deleted all driver files, *.tdb files, and logs. Restarted smb
and nmb with -d 10, did cupsaddsmb and rpcclient getdriver.
Comment 4 Alexey Zilber 2003-08-12 22:11:11 UTC
Created attachment 72 [details]
My smb.conf file.

My smb.conf file.
Comment 5 Alexey Zilber 2003-08-13 18:26:13 UTC
Comment on attachment 72 [details]
My smb.conf file.

There's some crap on the bottom of this config. I'm sending a new one, but in
makes no difference to the bug either way.
Comment 6 Alexey Zilber 2003-08-13 18:27:43 UTC
Created attachment 75 [details]
smb.conf
Comment 7 Alexey Zilber 2003-08-13 23:34:46 UTC
Created attachment 76 [details]
 rpcclient -d 10 -U'root%secret' Printboy -c 'getdriver "Canon" 3'
Comment 8 Gerald (Jerry) Carter 2003-08-14 13:50:43 UTC
My bug.   WIN40 version should always be 0.  Never trust 
the client.  Patch checked into SAMBA_3_0 CVS.  Refer to 
changes to printing/nt_printing.c

Pointer in the log was:

  get_a_printer_driver_3: [DRIVERS/WIN40/2/Canon]
  construct_printer_driver_info_3: status: WERR_UNKNOWN_PRINTER_DRIVER
Comment 9 Alexey Zilber 2003-08-15 17:13:13 UTC
I've recompiled 3B3 with the contents of the current CVS source/printing
directory.  I get the same error.
Comment 10 Alexey Zilber 2003-08-15 17:16:59 UTC
Created attachment 84 [details]
rpcclient -d 10

rpcclient -d 10, gives the same error as before.  windows (win2k) having the
same problem as well.
Comment 11 Gerald (Jerry) Carter 2003-08-15 18:40:11 UTC
Fixed in cvs (for real this time).
Comment 12 Alexey Zilber 2003-08-18 05:46:29 UTC
Argh, still the same problem.  rpcclient shows more information now, but the
WERR_UNKNOWN_PRINTER_DRIVER is still there at the end.  Windows 2000 won't
install the driver through "Point'N'Click'.
Comment 13 Alexey Zilber 2003-08-18 05:49:27 UTC
Created attachment 86 [details]
rpcclient -d 10 for Samba 3rc1

Samba 3rc1
Comment 14 Gerald (Jerry) Carter 2003-08-19 07:33:13 UTC
The error in rpcclient looks like a bug in returning the
status code.   The WERR_UNKNOWN_PRINTER_DRIVER is returned
now due to the reqest for the "Windows NT PPC" architecture 
string.  The "Windows 4.0" and "WIndows NT x86" requests succeed.

I have not been able to reproduce the WIin2k point-n-print
failure yet.  Still trying.
Comment 15 Gerald (Jerry) Carter 2003-08-19 09:55:53 UTC
I've checked in a fix to workaround the failures.  If any 
architecture can be retreived, then the call is considered 
successful.  rpcclient will now also look for version 2 (nt4/2k) 
and 3 (2k/xp) Windows NT x86 drivers.
Comment 16 Gerald (Jerry) Carter 2003-08-19 11:07:50 UTC
I just installed the adobe win9x & nt4 drivers via cupsaddsmb
without any glitches.  Also ran rpcclient -c getdriver and connected 
to the printer from a 2k client.  Everything looks.  I need a level 
10 debug log of the 2k point-n-print failure to make any progress
on this.
Comment 17 Alexey Zilber 2003-08-19 20:50:36 UTC
Created attachment 87 [details]
Win2k Event Log

Shows a driver download.  But success? Failure? Unkown.
Comment 18 Gerald (Jerry) Carter 2003-08-19 21:36:26 UTC
I can read the latest attachment.  Bugzilla might have eaten it.
Only 344 bytes.  I need a level 10 smbd debug log of a failure 
when you are trying to connect to the print from a 2k client.
And what the error show on the client says.

If you are not seeing an error connecting from a 2k client, then
let's close this bug.
Comment 19 Alexey Zilber 2003-08-20 01:30:04 UTC
Created attachment 88 [details]
smbd and nmbd -d 10 logs

This is from a 4th win2k machine (no service packs) hanging around the office.
Same error as my Win2k SP3+ service pack machine.
Comment 20 Alexey Zilber 2003-08-20 01:36:45 UTC
The following is the result of rpcclient.  Pls note, the WinNT/2k/XP drivers are
the cups drivers, and the Win9x are the Adobe drivers:

# rpcclient -U'root%secret' Printboy -c 'getdriver "Canon" 3'

[Windows 4.0]
Printer Driver Info 3:
        Version: [0]
        Driver Name: [Canon]
        Architecture: [Windows 4.0]
        Driver Path: [\\printboy\print$\WIN40\0\ADOBEPS4.DRV]
        Datafile: [\\printboy\print$\WIN40\0\Canon.PPD]
        Configfile: []
        Helpfile: [\\printboy\print$\WIN40\0\ADOBEPS4.HLP]

        Dependentfiles: [\\printboy\print$\WIN40\0\ICONLIB.DLL]
        Dependentfiles: [\\printboy\print$\WIN40\0\DEFPRTR2.PPD]
        Dependentfiles: [\\printboy\print$\WIN40\0\ADFONTS.MFM]
        Dependentfiles: [\\printboy\print$\WIN40\0\PSMON.DLL]
        Dependentfiles: [\\printboy\print$\WIN40\0\ADOBEPS4.HLP]
        Dependentfiles: [\\printboy\print$\WIN40\0\Canon.PPD]
        Dependentfiles: [\\printboy\print$\WIN40\0\ADOBEPS4.DRV]

        Monitorname: [PSMON.DLL]
        Defaultdatatype: [RAW]


[Windows NT x86]
Printer Driver Info 3:
        Version: [2]
        Driver Name: [Canon]
        Architecture: [Windows NT x86]
        Driver Path: [\\printboy\print$\W32X86\2\cupsdrvr.dll]
        Datafile: [\\printboy\print$\W32X86\2\Canon.ppd]
        Configfile: [\\printboy\print$\W32X86\2\cupsui.dll]
        Helpfile: [\\printboy\print$\W32X86\2\cups.hlp]


        Monitorname: []
        Defaultdatatype: [RAW]

result was WERR_UNKNOWN_PRINTER_DRIVER
Comment 21 Alexey Zilber 2003-08-20 01:43:13 UTC
Created attachment 89 [details]
Screenshot on win2k of the bug.

Jpeg Screenshot of the problem.
Comment 22 Gerald (Jerry) Carter 2003-08-20 09:37:04 UTC
My current theory is windows 2000 does not like this 
version of the driver (its an nt driver).  Have you 
tried the adobe PS drivers?  

I'll try to reproduce this using the cups drivers and the 
canon ppd file.  If you didn't get the PPD file from cups.org,
could you send me a URL?  Thanks.

wrt to rpcclient, are you sure that are using 
the latest SAMBA_3_0 cvs code?  It doesn't look 
like it.
Comment 23 Alexey Zilber 2003-08-20 19:59:40 UTC
I will try using only the Adobe drivers.  The Canon.ppd file is autogenerated by
RH9 using foomatic.
Comment 24 Alexey Zilber 2003-08-20 20:04:24 UTC
Created attachment 92 [details]
My Canon PPD file generated by RH9/foomatic.
Comment 25 Alexey Zilber 2003-08-21 02:32:06 UTC
Created attachment 93 [details]
Some of the latest -d 10 logs for cvs.

This one is using ALL Adobe drivers.
Comment 26 Gerald (Jerry) Carter 2003-08-22 20:44:44 UTC
I have now successfully connected to the printer using an xp sp1 and 
a 2k sp3 client.  I installed the driver using cupsaddsmb.
The canon.pdd file was generated by foomatic on RH9.

The change that I made was to ensure that we always set the 
device name string in the DEVMODE to be \\server\share.

btw...you might also want to set "default devmode = yes" on in
the serice for this printer.
Comment 27 Alexey Zilber 2003-08-23 02:42:55 UTC
Jerry is DA MAN! My eternal gratitude.  That cinched the bug: default devmode = yes

Thank you!
Comment 28 Alexey Zilber 2003-08-23 02:53:27 UTC
Created attachment 102 [details]
Newest Screenshot.

Interesting, with cupsaddsmb or without I get the same thing.  Is it using the
Adobe drivers or straight PPD???
Comment 29 Gerald (Jerry) Carter 2003-08-23 07:22:04 UTC
devmode issues fixed.
Comment 30 Gerald (Jerry) Carter 2005-02-07 09:06:08 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 31 Gerald (Jerry) Carter 2005-08-24 10:25:36 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 32 Gerald (Jerry) Carter 2005-11-14 09:29:16 UTC
database cleanup