Bug 2896 - "Text file busy" in shell commands
"Text file busy" in shell commands
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.10
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 3093 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-19 02:32 UTC by fernando guillen suarez
Modified: 2006-01-04 08:19 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fernando guillen suarez 2005-07-19 02:32:02 UTC
(excuse for my english)
(maybe this bug has anything with: #1962)

It was a very rare problems.

The commands like: 'whoami', 'hostname', 'umount', 'dircolors' and other..
didn't work, the message that i read was: "Text file busy", for example:

$ whoami
-bash: /usr/bin/whoami: Text file busy 

The problem was a samba problem, I killed all 'smbd' process and every thing
become fine.

At the same time that the problem borned, I can read this on the syslog:[1], 
and on the samba log:[2].

OS: Gentoo
kernel: 2.6.11-gentoo-r9
samba: 3.0.10

thanks for all your work.
fernando.





[1]--------------------
Jul 18 20:30:03 wasa1 smbd[6297]: [2005/07/18 20:30:03, 0]
locking/brlock.c:brl_lock(373)
Jul 18 20:30:03 wasa1 smbd[6297]:   client sent 0/0 lock - please report this
Jul 18 20:30:03 wasa1 smbd[6297]: [2005/07/18 20:30:03, 0]
locking/brlock.c:brl_lock(373)
Jul 18 20:30:03 wasa1 smbd[6297]:   client sent 0/0 lock - please report this
Jul 18 20:30:04 wasa1 smbd[6297]: [2005/07/18 20:30:04, 0]
locking/brlock.c:brl_lock(373)
Jul 18 20:30:04 wasa1 smbd[6297]:   client sent 0/0 lock - please report this
Jul 18 20:30:04 wasa1 smbd[6297]: [2005/07/18 20:30:04, 0]
locking/brlock.c:brl_lock(373)
Jul 18 20:30:04 wasa1 smbd[6297]:   client sent 0/0 lock - please report this
Jul 18 20:30:04 wasa1 smbd[6297]: [2005/07/18 20:30:04, 0]
locking/brlock.c:brl_lock(373)
Jul 18 20:30:04 wasa1 smbd[6297]:   client sent 0/0 lock - please report this
Jul 18 20:30:05 wasa1 smbd[6297]: [2005/07/18 20:30:05, 0]
locking/brlock.c:brl_lock(373)
Jul 18 20:30:05 wasa1 smbd[6297]:   client sent 0/0 lock - please report this
Jul 18 20:30:05 wasa1 smbd[6297]: [2005/07/18 20:30:05, 0]
locking/brlock.c:brl_lock(373)
Jul 18 20:30:05 wasa1 smbd[6297]:   client sent 0/0 lock - please report this
Jul 18 20:30:05 wasa1 smbd[6297]: [2005/07/18 20:30:05, 0]
locking/brlock.c:brl_lock(373)
Jul 18 20:30:05 wasa1 smbd[6297]:   client sent 0/0 lock - please report this
Jul 18 20:30:30 wasa1 kernel: lease broken - owner pid = 6214
Jul 18 20:30:45 wasa1 kernel: lease broken - owner pid = 6214 


[2]------------------
# grep "18 20:" /var/log/samba/log.* 
/var/log/samba/log.pc4167:[2005/07/18 20:28:17, 1]
smbd/service.c:make_connection_snum(648)
/var/log/samba/log.pc4167:[2005/07/18 20:28:35, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:30:03, 1]
smbd/service.c:make_connection_snum(648)
/var/log/samba/log.pc4167:[2005/07/18 20:30:03, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:30:03, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:30:04, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:30:04, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:30:04, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:30:05, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:30:05, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:30:05, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:31:11, 1]
smbd/service.c:make_connection_snum(648)
/var/log/samba/log.pc4167:[2005/07/18 20:31:11, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:31:11, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:31:11, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:31:12, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:31:12, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:31:12, 0] locking/brlock.c:brl_lock(373)
/var/log/samba/log.pc4167:[2005/07/18 20:31:12, 0] locking/brlock.c:brl_lock(373)
Comment 1 fernando guillen suarez 2005-07-19 02:42:41 UTC
more information:

the pc4167 that opened the conexion that made the error had mounted the resouce
/ (the root file system).. maybe this machine mounted this resource and blocked
the access to this resource.

the machine is a windows.
Comment 2 Gerald (Jerry) Carter 2005-09-28 07:16:10 UTC
Try setting 'kernel oplocks = no'.  
Comment 3 Gerald (Jerry) Carter 2005-09-29 05:08:20 UTC
*** Bug 3093 has been marked as a duplicate of this bug. ***
Comment 4 Gerald (Jerry) Carter 2006-01-04 08:19:37 UTC
closing.  no response from reporter.  SOunds more like a kernel bug anyways.