Bug 2716 - editreg doesn't compile
editreg doesn't compile
Status: RESOLVED DUPLICATE of bug 2280
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
3.0.14a
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-14 07:25 UTC by Raoul D
Modified: 2005-05-18 05:33 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raoul D 2005-05-14 07:25:16 UTC
Cannot compile editreg, even though the rest compiled fine.

Below are the errors I get:

/usr/src/samba-3.0.14a/source# make bin/editreg
Compiling utils/editreg.c
utils/editreg.c:329:1: warning: "IVAL" redefined
In file included from include/includes.h:824,
                 from utils/editreg.c:320:
include/byteorder.h:139:1: warning: this is the location of the previous definition
utils/editreg.c:335:1: warning: "SVAL" redefined
include/byteorder.h:137:1: warning: this is the location of the previous definition
utils/editreg.c:339:1: warning: "CVAL" redefined
include/byteorder.h:108:1: warning: this is the location of the previous definition
utils/editreg.c:341:1: warning: "SIVAL" redefined
include/byteorder.h:148:1: warning: this is the location of the previous definition
utils/editreg.c:347:1: warning: "SSVAL" redefined
include/byteorder.h:147:1: warning: this is the location of the previous definition
utils/editreg.c:367: error: conflicting types for `NTTIME'
include/smb.h:217: error: previous declaration of `NTTIME'
utils/editreg.c:442: error: conflicting types for `SEC_DESC'
include/rpc_secdes.h:187: error: previous declaration of `SEC_DESC'
utils/editreg.c: In function `nt_key_iterator':
utils/editreg.c:754: error: `__ERROR__XX__NEVER_USE_STRCAT___' undeclared (first
use in this function)
utils/editreg.c:754: error: (Each undeclared identifier is reported only once
utils/editreg.c:754: error: for each function it appears in.)
utils/editreg.c:1123:61: macro "SMB_REALLOC_ARRAY" requires 3 arguments, but
only 2 given
utils/editreg.c: In function `nt_add_reg_value':
utils/editreg.c:1121: error: `SMB_REALLOC_ARRAY' undeclared (first use in this
function)
utils/editreg.c: In function `process_vk':
utils/editreg.c:2097: error: `__ERROR__XX__NEVER_USE_BCOPY___' undeclared (first
use in this function)
utils/editreg.c: At top level:
utils/editreg.c:2627: error: conflicting types for `sid_size'
include/proto.h:1181: error: previous declaration of `sid_size'
utils/editreg.c:2675: error: conflicting types for `sec_desc_size'
include/proto.h:544: error: previous declaration of `sec_desc_size'
utils/editreg.c: In function `print_flags':
utils/editreg.c:3833: error: `__ERROR__XX__NEVER_USE_STRCAT___' undeclared
(first use in this function)
utils/editreg.c: In function `main':
utils/editreg.c:3998: warning: passing arg 1 of `free' discards qualifiers from
pointer target type
make: *** [utils/editreg.o] Error 1
Comment 1 Raoul D 2005-05-17 15:48:18 UTC
Unfortunately, I just noticed that this is a dupe of bug #2280 which is marked
as wontfix.

Too bad, because it would be really nice to have that functionality. I still
hope someone will be willing to fix it.


*** This bug has been marked as a duplicate of 2280 ***
Comment 2 Gerald (Jerry) Carter 2005-05-18 05:33:59 UTC
There's a new registry i/o lib being built in trunk that will 
be eventually backported to Samba 3.0.x.  So editreg (which never 
really worked anyways) is ireelevant.