Bug 2280 - editreg does not compile
editreg does not compile
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.10
All All
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
: 2716 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-27 02:42 UTC by Björn Jacke
Modified: 2005-05-17 15:49 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2005-01-27 02:42:52 UTC
in pre2 editreg does not compile:

Compiling utils/log2pcaphex.c
utils/log2pcaphex.c: In function `read_log_data':
utils/log2pcaphex.c:211: warning: long unsigned int format, different type arg
(arg 3)
utils/log2pcaphex.c: In function `main':
utils/log2pcaphex.c:228: warning: `data_bytes_read' might be used uninitialized
in this function
Linking bin/log2pcap
Compiling utils/editreg.c
utils/editreg.c:329:1: warning: "IVAL" redefined
In file included from include/includes.h:825,
                 from utils/editreg.c:320:
include/byteorder.h:117:1: warning: this is the location of the previous definition
utils/editreg.c:335:1: warning: "SVAL" redefined
include/byteorder.h:116:1: warning: this is the location of the previous definition
utils/editreg.c:339:1: warning: "CVAL" redefined
include/byteorder.h:108:1: warning: this is the location of the previous definition
utils/editreg.c:341:1: warning: "SIVAL" redefined
include/byteorder.h:123:1: warning: this is the location of the previous definition
utils/editreg.c:347:1: warning: "SSVAL" redefined
include/byteorder.h:122:1: warning: this is the location of the previous definition
utils/editreg.c:367: error: conflicting types for `NTTIME'
include/smb.h:217: error: previous declaration of `NTTIME'
utils/editreg.c:442: error: conflicting types for `SEC_DESC'
include/rpc_secdes.h:187: error: previous declaration of `SEC_DESC'
utils/editreg.c: In function `nt_key_iterator':
utils/editreg.c:754: error: `__ERROR__XX__NEVER_USE_STRCAT___' undeclared (first
use in this function)
utils/editreg.c:754: error: (Each undeclared identifier is reported only once
utils/editreg.c:754: error: for each function it appears in.)
utils/editreg.c: In function `nt_add_reg_value':
utils/editreg.c:1087: warning: implicit declaration of function `assert'
utils/editreg.c:1123:61: macro "SMB_REALLOC_ARRAY" requires 3 arguments, but
only 2 given
utils/editreg.c:1121: error: `SMB_REALLOC_ARRAY' undeclared (first use in this
function)
utils/editreg.c: In function `data_to_ascii':
utils/editreg.c:1611: warning: cast from pointer to integer of different size
utils/editreg.c:1611: warning: cast from pointer to integer of different size
utils/editreg.c:1617: warning: cast from pointer to integer of different size
utils/editreg.c:1617: warning: cast from pointer to integer of different size
utils/editreg.c: In function `nt_get_regf_hdr':
utils/editreg.c:1710: warning: cast from pointer to integer of different size
utils/editreg.c: In function `process_sk':
utils/editreg.c:1960: warning: cast from pointer to integer of different size
utils/editreg.c: In function `process_vk':
utils/editreg.c:2052: warning: cast from pointer to integer of different size
utils/editreg.c:2097: error: `__ERROR__XX__NEVER_USE_BCOPY___' undeclared (first
use in this function)
utils/editreg.c:2096: warning: unused variable `dat_ptr'
utils/editreg.c: In function `process_lf':
utils/editreg.c:2184: warning: cast from pointer to integer of different size
utils/editreg.c: In function `nt_get_key_tree':
utils/editreg.c:2242: warning: cast from pointer to integer of different size
utils/editreg.c:2260: warning: cast from pointer to integer of different size
utils/editreg.c:2262: warning: int format, different type arg (arg 3)
utils/editreg.c:2331: warning: cast from pointer to integer of different size
utils/editreg.c:2331: warning: cast from pointer to integer of different size
utils/editreg.c: At top level:
utils/editreg.c:2627: error: conflicting types for `sid_size'
include/proto.h:1207: error: previous declaration of `sid_size'
utils/editreg.c:2657: error: conflicting types for `acl_size'
/usr/include/sys/acl.h:114: error: previous declaration of `acl_size'
utils/editreg.c:2675: error: conflicting types for `sec_desc_size'
include/proto.h:547: error: previous declaration of `sec_desc_size'
utils/editreg.c: In function `print_flags':
utils/editreg.c:3833: error: `__ERROR__XX__NEVER_USE_STRCAT___' undeclared
(first use in this function)
utils/editreg.c: In function `main':
utils/editreg.c:3998: warning: passing arg 1 of `free' discards qualifiers from
pointer target type
/usr/include/inttypes.h: At top level:
utils/editreg.c:1287: warning: `nt_create_def_sec_desc' defined but not used
utils/editreg.c:1671: warning: `nt_free_regf' defined but not used
make: *** [utils/editreg.o] Error 1
Comment 1 Gerald (Jerry) Carter 2005-01-27 07:47:34 UTC
won't fix this one.  I already looked at it a couple of days ago.
it's was jelmer's project which apparently he has decidied is 
better suited for Samba4.  Note that editreg is not build by 
'make everything' either.

But if someone wants to take ownership of it, that's fine by me.
Comment 2 Gerald (Jerry) Carter 2005-02-07 07:34:55 UTC
originally reported against 3.0.11pre1.  Moving back to version to 3.0.10 
to remove preX and rcX versions.
Comment 3 Raoul D 2005-05-17 15:49:34 UTC
*** Bug 2716 has been marked as a duplicate of this bug. ***