Bug 2714 - smbclient Version 3.0.13-1.1-SUSE seems to ignore -p port parameter
smbclient Version 3.0.13-1.1-SUSE seems to ignore -p port parameter
Status: RESOLVED DUPLICATE of bug 2688
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
3.0.13
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-13 13:39 UTC by drmbx
Modified: 2005-05-13 15:49 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description drmbx 2005-05-13 13:39:22 UTC
After upgrading a system that was succesfully using an (older) version of samba 

I'm doing this smbclient //some_host/epson -I localhost -p 8005 -N

to connect to the remote printer queue. It was working with ver 2.2

I've setup a tcpdump -i lo port 8005 to capture any data going to port 8005 and
nothing happens when using the above mentioned smbclient command. No traffic is
sent to that port (although the debug info of smclients shows several attempts
to connect to ports 445 and 139).

It seems as if smbclient ignores the -p port parameter. Same result with 3.0.14a
binary from samba.org
Comment 1 Gerald (Jerry) Carter 2005-05-13 14:37:39 UTC

*** This bug has been marked as a duplicate of 2688 ***
Comment 2 drmbx 2005-05-13 15:25:49 UTC
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of 2688 ***

Sorry, I failed to see it when searching before posting.

It's fixed for me with part of the last patch on client.c mentioned on 2688


Maybe the search should return resolved issues too? (to prevent cases like mine)
Comment 3 drmbx 2005-05-13 15:49:07 UTC
> Maybe the search should return resolved issues too?

Right now I'm banging my head against the wall (yeah, now I can see the
open/closed/all combo box in the search ... silly me).