Bug 2688 - smbclient has stopped to recognize --port option
smbclient has stopped to recognize --port option
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.14a
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
: 2714 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-07 23:36 UTC by Roman Dubtsov
Modified: 2005-08-24 10:21 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Dubtsov 2005-05-07 23:36:54 UTC
for example:

$ smbclient --port 139 -d 10 -L //STORE 2>&1 | grep port
bind succeeded on port 0
Sending a packet of len 50 to (192.168.0.8) on port 137
read_udp_socket: lastip 192.168.0.8 lastport 137 read: 62
Received a packet of len 62 from (192.168.0.8) port 137
remove_duplicate_addrs2: looking for duplicate address/port pairs
Connecting to 192.168.0.2 at port 445
Comment 1 Gerald (Jerry) Carter 2005-05-08 05:58:02 UTC
This is debian BUG #id 307746.  I'll get it fixed up on Monday.
Comment 2 Gerald (Jerry) Carter 2005-05-09 15:37:19 UTC
see the patch attached to BUG 2680 for a fix.
Comment 3 Gerald (Jerry) Carter 2005-05-13 14:37:41 UTC
*** Bug 2714 has been marked as a duplicate of this bug. ***
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:21:33 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.