Bug 2609 - snprintf("%llul\n", ULLONG_MAX) not correct
snprintf("%llul\n", ULLONG_MAX) not correct
Status: RESOLVED DUPLICATE of bug 11947
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.9
All Linux
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-14 09:51 UTC by Sean Young
Modified: 2017-06-29 06:46 UTC (History)
1 user (show)

See Also:


Attachments
Fixes long long problems (1.99 KB, patch)
2005-04-14 10:20 UTC, Sean Young
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Young 2005-04-14 09:51:53 UTC
I've used the snprintf.c in my own project and found that it cannot print
ULLONG_MAX as the convert buffer is too small in fmtint() (off-by-one).
Comment 1 Sean Young 2005-04-14 10:20:27 UTC
Created attachment 1156 [details]
Fixes long long problems
Comment 2 Sean Young 2005-04-14 10:21:35 UTC
Also other long long issues resolved
Comment 3 Andrew Bartlett 2017-06-29 06:25:36 UTC
I'm very sorry for how long this was ignored.  As far as I read it, this was eventually fixed in Samba 4.3 and 4.4 thanks to a patch in bug 11947, so I'll close this as a duplicate of that bug.

The master commit was 8814b2556583e1f8965e8bf5a93438d46e8d43e6

Sorry for not addressing this earlier.

*** This bug has been marked as a duplicate of bug 11947 ***