Bug 2596 - Samba 3.0.15pre1 nmdb: Unresolved text symbol "become_root"
Samba 3.0.15pre1 nmdb: Unresolved text symbol "become_root"
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.13
SGI IRIX
: P3 major
: none
Assigned To: Tim Potter
Samba QA Contact
:
: 2599 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-12 11:04 UTC by Jason Mader
Modified: 2005-08-24 10:17 UTC (History)
2 users (show)

See Also:


Attachments
provide dummy become_root symbol (6.68 KB, patch)
2005-04-26 00:55 UTC, James Peach (outdated mail address)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Mader 2005-04-12 11:04:50 UTC
Linking bin/nmbd
ld32: ERROR   33 : Unresolved text symbol "become_root" -- 1st referenced by
lib/util.o.
        Use linker option -v to see when and which objects, archives and dsos
are loaded.
ld32: INFO    152: Output file removed because of error.
*** Error code 2 (bu21)
Comment 1 Tim Potter 2005-04-12 18:03:52 UTC
This is due to the become_root() call in smb_panic2() if HAVE_LIBEXC is defined.
 I guess this must be the case for IRIX.  The sad thing is that this isn't even
necessary in nmbd as it always runs as root.
Comment 2 Gerald (Jerry) Carter 2005-04-20 06:24:22 UTC
James, could you take a look at this one.  I thought we had already fixed all
these issues.
Comment 3 James Peach (outdated mail address) 2005-04-25 18:52:29 UTC
I have a patch for this .. will post in an hour or 2 ..
Comment 4 James Peach (outdated mail address) 2005-04-26 00:55:16 UTC
Created attachment 1173 [details]
provide dummy become_root symbol

This patch fixes Makefile.in so dummy_root is available everywhere it's
needed. I've also snuck in a small change to the IRIX backtrace code,
where there was a off-by-one error in providing space for function
names.
Comment 5 James Peach (outdated mail address) 2005-04-26 00:55:51 UTC
Looks like bug #2599 is a duplicate of this ..
Comment 6 Lars Müller 2005-04-26 01:34:13 UTC
*** Bug 2599 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Allison 2005-04-26 14:05:52 UTC
Applied, thanks.
Jeremy.
Comment 8 Gerald (Jerry) Carter 2005-08-24 10:17:20 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.