Bug 2569 - Add code to recognize *, :, |, <, >, ? and \ characters when remapped
Add code to recognize *, :, |, <, >, ? and \ characters when remapped
Status: CLOSED FIXED
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
2.6
All Linux
: P3 normal
: ---
Assigned To: Steve French
:
: 2568 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-02 21:09 UTC by Steve French
Modified: 2005-04-08 08:10 UTC (History)
0 users

See Also:


Attachments
test patch for remapping illegal chars (2.69 KB, patch)
2005-04-02 21:13 UTC, Steve French
no flags Details
revised version of patch (to fix accidental mapping of slash in \\server\share) (2.69 KB, patch)
2005-04-02 22:39 UTC, Steve French
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve French 2005-04-02 21:09:28 UTC
The illegal character set in Windows filenames is larger than that of POSIX
(which only forbids forward slash).  Recognize the remapped characters, and
remap them on the way out.
Comment 1 Steve French 2005-04-02 21:13:28 UTC
Created attachment 1134 [details]
test patch for remapping illegal chars

If feedback is good on this - I will code it.  I need to know whether it is
sufficient to make this feature a 
a) configure option (so it has to be explicitly built in)
or
b) whether it should be a /proc/fs/cifs runtime config option
or
c) both

It could also be made a mount option but that hits a lot more code - but that
could also be done.
Comment 2 Steve French 2005-04-02 22:38:58 UTC
*** Bug 2568 has been marked as a duplicate of this bug. ***
Comment 3 Steve French 2005-04-02 22:39:53 UTC
Created attachment 1135 [details]
revised version of patch (to fix accidental mapping of slash in \\server\share)

Turns out we can not map slash either (without more work on the patch)
since slash is in share name