Bug 2467 - rpc_server/srv_samr_nt.c: variables "num_sids" and "grp" set but never used
rpc_server/srv_samr_nt.c: variables "num_sids" and "grp" set but never used
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: libsmbclient
3.0.11
SGI IRIX
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 2477 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 12:33 UTC by Jason Mader
Modified: 2005-08-24 10:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Mader 2005-03-16 12:33:23 UTC
Compiling rpc_server/srv_samr_nt.c
cc-1552 cc: WARNING File = rpc_server/srv_samr_nt.c, Line = 1980
  The variable "num_sids" is set but never used.

        int i, num_gids, num_sids;
                         ^

cc-1552 cc: WARNING File = rpc_server/srv_samr_nt.c, Line = 4124
  The variable "grp" is set but never used.

        struct group *grp;
                      ^
Comment 1 Gerald (Jerry) Carter 2005-03-22 07:51:31 UTC
Fixed.
Comment 2 Gerald (Jerry) Carter 2005-03-22 10:01:21 UTC
*** Bug 2477 has been marked as a duplicate of this bug. ***
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:27:29 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.