Bug 2465 - lib/sysquotas_4A.c: "const char *" incompatbile with "caddr_t"
lib/sysquotas_4A.c: "const char *" incompatbile with "caddr_t"
Status: RESOLVED DUPLICATE of bug 2314
Product: Samba 3.0
Classification: Unclassified
Component: libsmbclient
3.0.11
SGI IRIX
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 11:58 UTC by Jason Mader
Modified: 2005-03-16 12:57 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Mader 2005-03-16 11:58:46 UTC
Samba 3.0.12rc1

Compiling lib/sysquotas_4A.c
cc-1164 cc: WARNING File = lib/sysquotas_4A.c, Line = 98
  Argument of type "const char *" is incompatible with parameter of type
          "caddr_t".

                        if ((ret = quotactl(QCMD(Q_GETQUOTA,USRQUOTA), bdev,
id.uid, (void *)&D))&&errno != EDQUOT) {
                                                                       ^

cc-1164 cc: WARNING File = lib/sysquotas_4A.c, Line = 134
  Argument of type "const char *" is incompatible with parameter of type
          "caddr_t".

                        if ((ret = quotactl(QCMD(Q_GETQUOTA,USRQUOTA), bdev,
id.uid, (void *)&D))==0) {
                                                                       ^

cc-1164 cc: WARNING File = lib/sysquotas_4A.c, Line = 205
  Argument of type "const char *" is incompatible with parameter of type
          "caddr_t".

                        ret = quotactl(QCMD(Q_SETQLIM,USRQUOTA), bdev, id.uid,
(void *)&D);
                                                                 ^

cc-1164 cc: WARNING File = lib/sysquotas_4A.c, Line = 260
  Argument of type "const char *" is incompatible with parameter of type
          "caddr_t".

                        if ((ret = quotactl(QCMD(Q_GETQUOTA,USRQUOTA), bdev,
id.uid, (void *)&D))==0) {
                                                                       ^
Comment 1 Jason Mader 2005-03-16 12:57:23 UTC

*** This bug has been marked as a duplicate of 2314 ***