Bug 2314 - lib/sysquotas_4A.c: type "const char *" is incompatible with "caddr_t"
lib/sysquotas_4A.c: type "const char *" is incompatible with "caddr_t"
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.11
SGI IRIX
: P4 normal
: none
Assigned To: James Peach (outdated mail address)
Samba QA Contact
:
: 2465 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-05 14:21 UTC by Jason Mader
Modified: 2005-08-24 10:28 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Mader 2005-02-05 14:21:18 UTC
Compiling lib/sysquotas_4A.c
cc-1164 cc: WARNING File = lib/sysquotas_4A.c, Line = 98
  Argument of type "const char *" is incompatible with parameter of type
          "caddr_t".

                        if ((ret = quotactl(QCMD(Q_GETQUOTA,USRQUOTA), bdev,
id.uid, (void *)&D))&&errno != EDQUOT) {
                                                                       ^

cc-1164 cc: WARNING File = lib/sysquotas_4A.c, Line = 134
  Argument of type "const char *" is incompatible with parameter of type
          "caddr_t".

                        if ((ret = quotactl(QCMD(Q_GETQUOTA,USRQUOTA), bdev,
id.uid, (void *)&D))==0) {
                                                                       ^

cc-1164 cc: WARNING File = lib/sysquotas_4A.c, Line = 205
  Argument of type "const char *" is incompatible with parameter of type
          "caddr_t".

                        ret = quotactl(QCMD(Q_SETQLIM,USRQUOTA), bdev, id.uid,
(void *)&D);
                                                                 ^

cc-1164 cc: WARNING File = lib/sysquotas_4A.c, Line = 260
  Argument of type "const char *" is incompatible with parameter of type
          "caddr_t".

                        if ((ret = quotactl(QCMD(Q_GETQUOTA,USRQUOTA), bdev,
id.uid, (void *)&D))==0) {
                                                                       ^
Comment 1 Jason Mader 2005-02-05 14:41:23 UTC
On Irix in <sys/quotas.h>

/*
 * Definitions for the 'quotactl' system call for file system quotas.
 */
#ifndef _KERNEL
extern int quotactl(int, caddr_t , int, caddr_t);
#endif /* !_KERNEL */
Comment 2 Jason Mader 2005-03-16 12:57:25 UTC
*** Bug 2465 has been marked as a duplicate of this bug. ***
Comment 3 Gerald (Jerry) Carter 2005-03-24 06:26:10 UTC
lowering priority
Comment 4 James Peach (outdated mail address) 2005-07-30 22:45:54 UTC
Reassign IRIX bugs to me.
Comment 5 James Peach (outdated mail address) 2005-08-07 16:47:30 UTC
Fixed in
        http://websvn.samba.org/cgi-bin/viewcvs.cgi?rev=9203&view=rev
Comment 6 Gerald (Jerry) Carter 2005-08-24 10:28:01 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.