Bug 2404 - smb panic brings down all shares
smb panic brings down all shares
Status: RESOLVED DUPLICATE of bug 2396
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.9
x86 Linux
: P3 critical
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-01 21:41 UTC by Karm
Modified: 2005-03-03 08:07 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karm 2005-03-01 21:41:17 UTC
Have not determine why this happens, but smb just "panics" and then all shares 
are not accessible.  I have to go to the machine and execute smbd as root.  
Then the shares are available.  Looked for the same stack trace in the bug 
database and did not find any. 
 
[2005/02/25 14:42:36, 1] smbd/sesssetup.c:reply_sesssetup_and_X_spnego(593) 
  Unknown packet in reply_sesssetup_and_X_spnego 
[2005/02/25 15:42:31, 1] smbd/sesssetup.c:reply_sesssetup_and_X_spnego(593) 
  Unknown packet in reply_sesssetup_and_X_spnego 
[2005/02/25 15:42:31, 1] smbd/sesssetup.c:reply_sesssetup_and_X_spnego(593) 
  Unknown packet in reply_sesssetup_and_X_spnego 
[2005/02/25 16:01:48, 1] smbd/sesssetup.c:reply_sesssetup_and_X_spnego(593) 
  Unknown packet in reply_sesssetup_and_X_spnego 
[2005/02/25 16:01:48, 1] smbd/sesssetup.c:reply_sesssetup_and_X_spnego(593) 
  Unknown packet in reply_sesssetup_and_X_spnego 
[2005/02/25 17:13:22, 0] lib/fault.c:fault_report(36) 
  =============================================================== 
[2005/02/25 17:13:22, 0] lib/fault.c:fault_report(37) 
  INTERNAL ERROR: Signal 11 in pid 4605 (3.0.9-2.3-SUSE) 
  Please read the appendix Bugs of the Samba HOWTO collection 
[2005/02/25 17:13:22, 0] lib/fault.c:fault_report(39) 
  =============================================================== 
[2005/02/25 17:13:22, 0] lib/util.c:smb_panic2(1482) 
  PANIC: internal error 
[2005/02/25 17:13:22, 0] lib/util.c:smb_panic2(1490) 
  BACKTRACE: 13 stack frames: 
   #0 /usr/sbin/smbd(smb_panic2+0x120) [0x8202160] 
   #1 /usr/sbin/smbd(smb_panic+0x26) [0x8202336] 
   #2 /usr/sbin/smbd [0x81ed210] 
   #3 [0xffffe420] 
   #4 /usr/sbin/smbd(cups_printer_fn+0x447) [0x81e5827] 
   #5 /usr/sbin/smbd(pcap_printer_fn+0x8e) [0x81e305e] 
   #6 /usr/sbin/smbd(add_all_printers+0x32) [0x81e93c2] 
   #7 /usr/sbin/smbd(load_printers+0xa7) [0x81e9477] 
   #8 /usr/sbin/smbd(check_reload+0xc7) [0x80db617] 
   #9 /usr/sbin/smbd [0x82828d3] 
   #10 /usr/sbin/smbd(main+0x3fa) [0x828333a] 
   #11 /lib/tls/libc.so.6(__libc_start_main+0xe0) [0xb7c4db10] 
   #12 /usr/sbin/smbd [0x8079701] 
[2005/02/25 17:13:23, 1] smbd/service.c:close_cnum(835) 
  rbcbuild-brd (10.91.124.229) closed connection to service d 
[2005/02/25 17:13:49, 0] lib/fault.c:fault_report(36) 
  =============================================================== 
[2005/02/25 17:13:49, 0] lib/fault.c:fault_report(37) 
  INTERNAL ERROR: Signal 11 in pid 7068 (3.0.9-2.3-SUSE) 
  Please read the appendix Bugs of the Samba HOWTO collection 
[2005/02/25 17:13:49, 0] lib/fault.c:fault_report(39) 
  =============================================================== 
[2005/02/25 17:13:49, 0] lib/util.c:smb_panic2(1482) 
  PANIC: internal error 
[2005/02/25 17:13:49, 0] lib/util.c:smb_panic2(1490) 
  BACKTRACE: 14 stack frames: 
   #0 /usr/sbin/smbd(smb_panic2+0x120) [0x8202160] 
   #1 /usr/sbin/smbd(smb_panic+0x26) [0x8202336] 
   #2 /usr/sbin/smbd [0x81ed210] 
   #3 [0xffffe420] 
   #4 /usr/sbin/smbd(cups_printer_fn+0x447) [0x81e5827] 
   #5 /usr/sbin/smbd(pcap_printer_fn+0x8e) [0x81e305e] 
   #6 /usr/sbin/smbd(add_all_printers+0x32) [0x81e93c2] 
   #7 /usr/sbin/smbd(load_printers+0xa7) [0x81e9477] 
   #8 /usr/sbin/smbd(check_reload+0xc7) [0x80db617] 
   #9 /usr/sbin/smbd [0x80db775] 
   #10 /usr/sbin/smbd(smbd_process+0x104) [0x80dd674] 
   #11 /usr/sbin/smbd(main+0x530) [0x8283470] 
   #12 /lib/tls/libc.so.6(__libc_start_main+0xe0) [0xb7c4db10] 
   #13 /usr/sbin/smbd [0x8079701]
Comment 1 Gerald (Jerry) Carter 2005-03-03 08:07:11 UTC
did you read my comments for bug 2396 ?

*** This bug has been marked as a duplicate of 2396 ***