Bug 2336 - Printing from WinXP SP2 is *very* slow with some printers
Printing from WinXP SP2 is *very* slow with some printers
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.11
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-11 17:32 UTC by Justin Maggard
Modified: 2006-08-24 15:06 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Maggard 2005-02-11 17:32:12 UTC
Background:
The printer I found this behavior on most recently is a Dell 1700n Laser
Printer, but I've seen it on some Canon models in the past with earlier version
of Samba.  Tried with Samba 3.0.11 on Debian and Fedora Core 3.  Not all
printers exhibit this behavior.  It seems like it's only with certain drivers. 
Win2K and WinXP with no service pack or SP1 clients work fine at normal speed.
Problem:
I open the printer share from Network Neighborhood, select the Printer menu, and
select Properties.  Seemingly nothing happens for over a minute with the 1700n.
 Eventually the properties page comes up, but it takes a *long* time.

Here is my smb.conf:
[global]
 debug level = 2
 deadtime = 10
 delete readonly = 1
 delete veto files = 1
 encrypt passwords = 1
 follow symlinks = 0
 guest account = nobody
 invalid users = root
 load printers = 1
 max log size = 256
 name resolve order = "bcast wins"
 null passwords = 1
 obey pam restrictions = 1
 passwd program = "/usr/bin/passwd %u"
 preserve case = 1
 security = user
 server string = %h
 short preserve case = 1
 syslog = 0
 syslog only = 0
 unix password sync = 1
 veto files = "/.AppleDouble/Temporary Items/.AppleDB/.bin/.AppleDesktop/Network
Trash Folder/TheVolumeSettingsFolder/"
 wins server =
 workgroup = VOLUME
 
[printers]
 path = /var/spool/samba
 printable = 1
 public = 1
 use client driver = 1
====
I can get a smbd debug log if you need, but it tends to get very large.
Comment 1 Gerald (Jerry) Carter 2005-02-12 07:02:30 UTC
I don't think this is a bug in Samba.  At least based 
on the feedback from other on the samba list.

See These two links:

http://www.mail-archive.com/samba@lists.samba.org/msg48978.html
http://support.microsoft.com/default.aspx?scid=kb;en-us;329234









Comment 2 Nicolai Ehemann 2005-07-01 02:03:15 UTC
I think the problem is not solved, nor can savely be said that it is not a samba
issue (from what i found on the topic). 

We run Samba servers (3.0.14a) in an NT domain environment, with both Windows XP
sp1 and sp2 clients. Printing is set to cups. On some printers, with some
printer drivers, the problem of slow printing and slow opening of printer
dialogues occurs (current case is a HP 8150 DN - windows xp builtin driver
doesn't cause problems, current hp driver does).

The first link, leading to the discussion on the samba list, does indeed point
out  a working (at least for us) workaround - but it's not really practical, as
deleting registry keys every time after changing printer settings does not
really make sense. Additionally, these settings are important - in our special
case, the HP 8150 DN has a duplexer unit, which has to be enabled in the printer
settings.

The second link, pointing to the microsoft support article, is (in my mind)
totally out of context. Firstly, the support article describes problems with
accessing multiple network printers at once, secondly, the problem is described
as solved in service pack 2 (but our problem does only apply to service pack 2).

Please, do a review on this bug to make sure it really is a problem of windows.
Exactly the same applies for bug # 1821, which seems to be exactly the same
issue. That bug was closed with reference to printing bugfixes int 3.0.11, which
 obviously didn't solve this issue.

If you need configs or debug logs, please contact me.
Comment 3 Gerald (Jerry) Carter 2005-07-04 06:48:22 UTC
I've reviewed this bug with several people and everyone comes 
to the same conclusion that it is a Windows XP issue.
Unless you can provide evidence otherwise, this bug will
stay closed.
Comment 4 Luis A. Florit 2005-07-10 14:31:36 UTC
(In reply to comment #2)
> The first link, leading to the discussion on the samba list, does indeed point
> out  a working (at least for us) workaround - but it's not really practical, as
> deleting registry keys every time after changing printer settings does not
> really make sense. 

You are absolutely right. The problem is Windows what does not really make
sense... What I have done is a printer.reg file to be executed (just click on
it) after changing settings. Here it is (do not include the ##### line;
my printer appears like \\ORION\lp0 inside the Keys):

#######################################################################
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Printers\DevModePerUser]
"\\\\ORION\\lp0"=-
[HKEY_CURRENT_USER\Printers\DevModes2]
"\\\\ORION\\lp0"=-
Comment 5 Flavio do Carmo Junior 2006-08-24 15:06:40 UTC
http://www.gatago.com/linux/samba/14530473.html

On last message of this thread you'll find a solution..
This problem is not from Samba, this occurs because a poor code from spoolsv in SP2. 
This URL can help to understand:
http://support.microsoft.com/kb/893225

All thanks for Paul Griffith and sorry for my english ;)

here i'm pasting Paul's message for comments:
    *  Reply by: Paul Griffith |
    * Date: 17-02-2005 |
    * Show original


Try the following.

----

Thank you for choosing Online Support for your Microsoft Technical
Support offering. My name is Amy and I will be assisting you with
this service request. For your reference, the Case ID of this service request is
SRxxx.

In your case log, you've indicated that you have installed Service
Pack 2. However, when trying to print from a network printer, the
printer preference box and setup dialog box take a long time to load and
then, the print slows down. We shall be working to resolve this specific issue
through the course of the case. If I have misunderstood your concern,
please let
me know.




Before we go further, I would like to explain that the solution
mentioned in the KB329234 has been included in the installation of
Service Pack 2.
That is to say, if the problem occurs after installation Service Pack

2, it can be caused by different factor.

According to my experience, I suggest that we perform the steps
below to add this network printer to the local port of this SP2
computer and resolve the issue.

Let's now follow the steps to create a local printer, and then
redirect the port to the network server.

1. Click Start, click Control Panel and open Printers and Faxes.

2. In the left column, please choose Add A Printer.

3. Click Next and choose "Local Printer attached to this computer"
and click Next.

4. The printer wizard will search the printer and it will prompt you
that it cannot find a plug and play printer. Please click Next

5. Click to choose "Create a new port" and choose "Local Port";
click Next button.

6. Type in the server and printer name for the printer in
\\ServerName\PrinterName syntax in the pop up open box. Click OK.

7. Use the new port for the local printer.

If you are prompted for a password, there may not be a field in
Windows XP in which to enter a password. Reset the password on the
destination computer to be blank.

Restart the computer and test if our printer issue has been
resolved.


----

I hope that I can help ..

Flávio do Carmo Junior aka blk1d
Brazil
contact: billpp _at_ gmail _dot_ com