Bug 1821 - WindowsXP SP2 latest updates break printing
WindowsXP SP2 latest updates break printing
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.7
x86 Windows XP
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-24 15:36 UTC by Andreas Schiffler
Modified: 2005-08-24 10:17 UTC (History)
0 users

See Also:


Attachments
smb.conf from running system (22.26 KB, text/plain)
2004-10-15 13:00 UTC, Andreas Schiffler
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schiffler 2004-09-24 15:36:13 UTC
WindowsXP SP2 Printing Problem

Since the GDI+ update in XP SP2 printing does not work anymore. 

This is a showstopper bug as printing simply stops working for
affected clients. 

In fact, application will hang (essentially crash) when the Print option is 
selected.
SP1 clients are not affected. SP2 was working until a few days ago. 
Initially I was running 2.2.8a (Mandrake). Same effect. 
The I upgraded to 3.0.2 and now 3.0.7. Same effect.

Firewall settings to not affect this.

Which updates cause the grief? From the Windows Update log I can see that the 
core updates were 
.Net 1.0 SP3 .Net 1.1 GDI+ and MediaPlayer 10. Plus there were a few Office 
2002 updates. 
 

See http://www.ferzkopp.net/~aschiffler/samba.tar.gz for some 
level 10 logs with the bug in action.


Printer is "CanonS600". Host is .105 as andreas-compaq.

Procedure
- start smbd and nmbd with loglevel 10
- try to access printer "Properties"
- XP hangs
- wait a few seconds
- shutdown smb
- Windows responds with a "No driver installed ..." dialog



German list reference of bug

http://lists.spline.inf.fu-berlin.de/mailman/htdig/eisfair/2004-
August/066656.html
Comment 1 Volker Lendecke 2004-09-25 03:35:12 UTC
Tried to reproduce it, failed. German XPSP2 with the GDI+ update. Takes ages,
but still works.

The logs you provided are shortened, you probably have 'max log size = 100' or
so. Dramatically increase that, printing is very verbose. And please provide a
sniff as well, created by

tcpdump -i eth0 -n -s 1500 -w /tmp/sniff.cap host <client-ipaddr>

Volker
Comment 2 Andreas Schiffler 2004-09-27 05:49:08 UTC
Repeated the procedure for capturing traffic during the error condition with log
size 1M and also included a tcpdump.

http://www.ferzkopp.net/~aschiffler/samba-again.tar.gz

Procedure:
- start smb
- start tcpdump
- try to access "Properties" of samba printer "CanonS600"
- windows hangs
- stop tcpdump
- stop smb
- windows popups up a error dialog ("No printer driver ...")
Comment 3 Gerald (Jerry) Carter 2004-10-15 08:53:00 UTC
There's no driver assigned to the printer.


  000000 smb_io_printer_info_2
      000a80 smb_io_unistr servername
          0a80 unistr: \.\.1.9.2...1.6.8...0...1.9.9...
      0000 offset: 00000a80
      000a4c smb_io_unistr printername
          0a4c unistr: \.\.1.9.2...1.6.8...0...1.9.9.\.C.a.n.o.n.S.6.0.0...
      0004 offset: 00000a4c
      000a38 smb_io_unistr sharename
          0a38 unistr: C.a.n.o.n.S.6.0.0...
      0008 offset: 00000a38
      000a12 smb_io_unistr portname
          0a12 unistr: S.a.m.b.a. .P.r.i.n.t.e.r. .P.o.r.t...
      000c offset: 00000a12
      000a10 smb_io_unistr drivername
          0a10 unistr: ..
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Corrupted tdb?  The log file doesn't match up with your description 
that XP sp1 clients have no problems.  Looks like a configuration issue to me.
Comment 4 Andreas Schiffler 2004-10-15 09:48:40 UTC
But, I've NEVER assigned a printer driver on the Linux side of things for
printing to work. I always install the printer driver on the Windows side
manually on FILE: and then choose it manually when connecting to the share. We
also run a "write to PDF" which also stopped working.

Basically all updated SP2 clients stopped working while SP1 clients keept
happily printing away (obviously we didn't have any non-updated SP2 clients
anymore because its all automatic these days).

Still, it is possibly a configuration issue - What might need to be changed
configuration-wise to fix things? I'll try anything - we print from an old
Windows box at the moment.


(In reply to comment #3)
> There's no driver assigned to the printer.
> 
> 
>   000000 smb_io_printer_info_2
>       000a80 smb_io_unistr servername
>           0a80 unistr: \.\.1.9.2...1.6.8...0...1.9.9...
>       0000 offset: 00000a80
>       000a4c smb_io_unistr printername
>           0a4c unistr: \.\.1.9.2...1.6.8...0...1.9.9.\.C.a.n.o.n.S.6.0.0...
>       0004 offset: 00000a4c
>       000a38 smb_io_unistr sharename
>           0a38 unistr: C.a.n.o.n.S.6.0.0...
>       0008 offset: 00000a38
>       000a12 smb_io_unistr portname
>           0a12 unistr: S.a.m.b.a. .P.r.i.n.t.e.r. .P.o.r.t...
>       000c offset: 00000a12
>       000a10 smb_io_unistr drivername
>           0a10 unistr: ..
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> 
> Corrupted tdb?  The log file doesn't match up with your description 
> that XP sp1 clients have no problems.  Looks like a configuration issue to me.
> 

Comment 5 Gerald (Jerry) Carter 2004-10-15 12:33:22 UTC
could you attach your smb.conf for me to look at?  Thanks.
Comment 6 Andreas Schiffler 2004-10-15 13:00:22 UTC
Created attachment 730 [details]
smb.conf from running system

As requested by Jerry.
Comment 7 Larry Finger 2004-11-21 09:47:33 UTC
On my system this problem did not stop printing, but made it agonizingly slow. 
I was able to fix it by deleting the printers on the Windows client. On the 
Linux box, I stopped Samba, deleted the nt*.tdb files, and restarted Samba. On 
the Windows side, I used Windows Explorer to browse to the Printers and Faxes 
section of the Samba share, right-clicked on the white space and selected 
Server Properties, then reinstalled the drivers into the appropriate W32X86 
folder on the server. After reinstalling the printer on the Windows machine, 
proper speed was restored.
Comment 8 Gerald (Jerry) Carter 2005-02-03 07:22:09 UTC
reports are that printing is working fine in 3.0.11rc1.
Comment 9 Luis A. Florit 2005-07-10 14:21:49 UTC
(In reply to comment #8)
> reports are that printing is working fine in 3.0.11rc1.

Unfortunately not.
I have samba-3.0.14a-2 in FC4 with kernel 2.6.12-1.1387,
and the same problem persists.
The only workaround I found is to change windows registry before each print.
Comment 10 Gerald (Jerry) Carter 2005-07-12 13:30:56 UTC
Luis,  I can't fix windows client bugs and am not going to open a 
new bug report without more evidence that Samba is doing something
incorrectly.
Comment 11 Gerald (Jerry) Carter 2005-08-24 10:17:09 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.