Bug 2331 - Unable to rename XP host inside samba domain
Unable to rename XP host inside samba domain
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.21a
x86 Windows XP
: P3 critical
: none
Assigned To: Guenther Deschner
Samba QA Contact
:
: 2332 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-11 02:56 UTC by bremchandar
Modified: 2006-02-22 04:58 UTC (History)
0 users

See Also:


Attachments
allow account rename in samrsetuserinfo level 21 (3.21 KB, patch)
2006-01-11 12:26 UTC, Guenther Deschner
no flags Details
corrected patch (5.80 KB, patch)
2006-02-17 11:24 UTC, Guenther Deschner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bremchandar 2005-02-11 02:56:19 UTC
We are unable to rename the system after logging in as Local Admin as well as 
domain admin.We are prompted for the Domain Admin user name & password.Upon 
giving them correctly also, its throwing an "Access Denied" Message for 
renaming.
This is highly critical.Pls look into this.

Thanks,
Brem.
Comment 1 Volker Lendecke 2005-02-11 03:19:20 UTC
Could you please provide a debug level 10 log of the smbd that your XP workstation is trying to rename its workstation account against?  Thanks,  Volker 
Comment 2 Volker Lendecke 2005-02-11 04:23:00 UTC
I'm afraid this is not the right log file. You seem to have set 'log file = /var/log/samba/log.%m' or something similar. Please attach the log file specific to the connecting client machine.  Please also add your smb.conf.  Volker 
Comment 3 Gerald (Jerry) Carter 2005-02-11 06:57:01 UTC
*** Bug 2332 has been marked as a duplicate of this bug. ***
Comment 4 Volker Lendecke 2005-02-12 02:52:01 UTC
Ok, got your correct logfile. What we need to do is if a user is renamed with the setuserinfo2 issue a ldap modrdn operation. Either that or have a 'rename user script'. I would probably go for another case of 'ldapsam:trusted = yes', only support renaming users properly for the case that posixaccounts and samba accounts are on the same dn.  Jerry, what do you think?  Volker 
Comment 5 Andrew Bartlett 2005-09-08 15:56:44 UTC
There is a patch in bugzilla somewhere to support exactly this rename.

I really wish I had just got it in when I first saw it...
Comment 6 Guenther Deschner 2006-01-11 12:26:55 UTC
Created attachment 1666 [details]
allow account rename in samrsetuserinfo level 21

This patch is diffed against trunk but should work against SAMBA_3_0 as well. 
We need to find a better way to workaround the $/_ substitution though.
Comment 7 Guenther Deschner 2006-02-17 11:24:12 UTC
Created attachment 1735 [details]
corrected patch

New version of the patch; applies to 3_0 and trunk.
Comment 8 Guenther Deschner 2006-02-22 04:58:55 UTC
Fixed in Subversion.