Bug 2266 - rpc/nettype.h doesn't present on all the systems - requires configure check
rpc/nettype.h doesn't present on all the systems - requires configure check
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.10
All FreeBSD
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
: 2178 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-19 21:32 UTC by Timur Bakeyev
Modified: 2005-08-24 10:20 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur Bakeyev 2005-01-19 21:32:20 UTC
This header file is included from smbd/quotas.c.

Namely, FreeBSD 4 misses it. Apparently, although FreeBSD 5 has it, quotas.c
compiles nicelly with it excluded... So, our local patch is just:

-#include <rpc/nettype.h>

But as a reall solution for the build environment I guess it should be checked
in the confugure and wrapped into #ifdef. Sorry, no patch at the moment, but
it's trivial to make anyhow...
Comment 1 Gerald (Jerry) Carter 2005-02-01 11:12:27 UTC
fixed.
Comment 2 Gerald (Jerry) Carter 2005-02-03 07:18:38 UTC
*** Bug 2178 has been marked as a duplicate of this bug. ***
Comment 3 Gerald (Jerry) Carter 2005-02-07 07:34:54 UTC
originally reported against 3.0.11pre1.  Moving back to version to 3.0.10 
to remove preX and rcX versions.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:20:47 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.