Bug 2178 - patch for FreeBSD "ifdef" clause
patch for FreeBSD "ifdef" clause
Status: RESOLVED DUPLICATE of bug 2266
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.10
All FreeBSD
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-21 05:48 UTC by Ilia Chipitsine
Modified: 2005-02-03 07:18 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ilia Chipitsine 2004-12-21 05:48:05 UTC
that patch exists within FreeBSD Ports collection, it's better to have it in
main source tree.


--- smbd/quotas.c.orig  Tue Dec 21 16:51:38 2004
+++ smbd/quotas.c       Tue Dec 21 16:59:34 2004
@@ -938,7 +938,6 @@
 #include <rpc/rpc.h>
 #include <rpc/types.h>
 #include <rpcsvc/rquota.h>
-#include <rpc/nettype.h>
 #include <rpc/xdr.h>

 static int quotastat;
Comment 1 Gerald (Jerry) Carter 2005-02-03 07:18:36 UTC
fixed for 3.0.11.

*** This bug has been marked as a duplicate of 2266 ***