Bug 2224 - [patch] Makefile broken on Solaris using Forte compiler & gnu make + Solution
[patch] Makefile broken on Solaris using Forte compiler & gnu make + Solution
Status: RESOLVED DUPLICATE of bug 2623
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.9
Sparc Solaris
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
: 1965 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-07 07:18 UTC by Olaf Imig
Modified: 2005-05-09 06:53 UTC (History)
1 user (show)

See Also:


Attachments
patch for described bug (1.51 KB, patch)
2005-01-07 07:24 UTC, Olaf Imig
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Imig 2005-01-07 07:18:19 UTC
In the above described enviroment the build of samba since version 3.0.1 fail.
The reason is a failure in the rules for the PIC-Objects in Makefile.in:
.c.@PICSUFFIX@:
...
@$(CC) -I. -I$(srcdir) $(FLAGS) @PICFLAGS@ -c $< -o $*.@PICSUFFIX@
...
The rules works for gcc, because the PICSUFFIX is po and $*.@PICSUFFIX@ is
example.po. For the Forte compiler the PICSUFFIX is po.o, because the compiler
only produce objects with suffix .o. In this case $*.@PICSUFFIX@ is
example.po.po.o. 
Very simple solution:
Change all rules with PICSUFFIX in

@$(CC) -I. -I$(srcdir) $(FLAGS) @PICFLAGS@ -c $< -o $@

I think that works for all compiler, I tested it for gcc and cc on my platform.
Comment 1 Olaf Imig 2005-01-07 07:24:36 UTC
Created attachment 880 [details]
patch for described bug
Comment 2 Gerald (Jerry) Carter 2005-02-17 09:56:40 UTC
*** Bug 1965 has been marked as a duplicate of this bug. ***
Comment 3 Gerald (Jerry) Carter 2005-05-09 06:53:00 UTC

*** This bug has been marked as a duplicate of 2623 ***