Bug 1965 - [patch] Problem building libsmbclient.so using Sun's compiler
[patch] Problem building libsmbclient.so using Sun's compiler
Status: RESOLVED DUPLICATE of bug 2224
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.7
All All
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-23 12:00 UTC by Nicholas Brealey
Modified: 2005-02-17 09:56 UTC (History)
0 users

See Also:


Attachments
Fix build problem wiih dynconfig.po.o and lib/version.po.o (1.12 KB, patch)
2004-10-23 12:07 UTC, Nicholas Brealey
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Brealey 2004-10-23 12:00:54 UTC
With 3.0.7 and SVN version on Solaris with GNU make and Sun compilers 
and build smbwarpper I get:

make
...
Linking libsmbclient non-shared library bin/libsmbclient.a
ar: cannot open dynconfig.po.o
	No such file or directory
ar: cannot open lib/version.po.o
	No such file or directory
ar: dynconfig.po.o not found
ar: lib/version.po.o not found
make: [bin/libsmbclient.a] Error 2 (ignored)
Linking libsmbclient shared library bin/libsmbclient.so
ld: fatal: file dynconfig.po.o: open failed: No such file or directory
ld: fatal: file lib/version.po.o: open failed: No such file or directory
ld: fatal: File processing errors. No output written to bin/libsmbclient.so
make: *** [bin/libsmbclient.so] Error 1

Files dynconfig.po.po.o and lib/version.po.po.o do exist.

The problem is that the rules for dynconfig.@PICSUFFIX@ and
lib/version.@PICSUFFIX@ use the $* macro which to give the
stem of the target name but this only works as the author of the Makefile
template expected in rules like %.po.o: %.c. The fix is to use the $@ macro instead.

I will attach at patch.
Comment 1 Nicholas Brealey 2004-10-23 12:07:37 UTC
Created attachment 742 [details]
Fix build problem wiih dynconfig.po.o and  lib/version.po.o
Comment 2 Gerald (Jerry) Carter 2005-02-17 09:56:39 UTC

*** This bug has been marked as a duplicate of 2224 ***