Bug 2174 - the default "use spnego = yes" is not good for WM2003SE
the default "use spnego = yes" is not good for WM2003SE
Status: RESOLVED DUPLICATE of bug 1828
Product: Samba 3.0
Classification: Unclassified
Component: ntlm_auth tool
All Linux
: P3 major
: none
Assigned To: Andrew Bartlett
Samba QA Contact
: 1153 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2004-12-19 16:57 UTC by Sunil
Modified: 2005-02-24 08:43 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Sunil 2004-12-19 16:57:04 UTC
If I don't set the parameter "use spnego = no" in my server smb.conf, I can't
connect from a pocket pc client running WM2003SE. There is no problem accessing
the server from XP or W2K.

The error that client gets is either '53' or '58' with 'could not connect' as
the message string.
Comment 1 Andrew Bartlett 2004-12-22 18:59:15 UTC
We are going to need much more details than that.  Try attaching an ethereal
trace, and logfiles.

What do you mean by WM2003SE btw?
Comment 2 Sunil 2004-12-22 20:08:27 UTC
Windows Mobile 2003 Second Edition is the operating system running on the pocket
PC. The client on pocket PC can't connect to the samba shares if "use spnego =
no" is not set.

I am not sure what that parameter does exactly but it seems to work only for
windows XP and windows 2000.

What all logs you need? I am hesitant to screw the working setup but I will try
to go back and fetch you some logs. Let me know which files are you interested in.
Comment 3 Andrew Bartlett 2004-12-22 20:27:29 UTC
An ethereal sniff of the connection (showing the failed login) could tell us a lot.

I suspect I know what is going on here, and I *think* it is fixed in Samba4.  If
you have a spare machine, and wish to confirm that, it would be interesting. 
(Samba4 is far from production however, but we took the opportunity to get a few
things right).

Andrew Bartlett
Comment 4 Gerald (Jerry) Carter 2005-02-09 08:33:22 UTC
*** Bug 1153 has been marked as a duplicate of this bug. ***
Comment 5 Gerald (Jerry) Carter 2005-02-09 08:39:43 UTC
no reply in over a month. closing.
Comment 6 Gerald (Jerry) Carter 2005-02-24 08:43:43 UTC
actually a duplicate bug report.
Comment 7 Gerald (Jerry) Carter 2005-02-24 08:43:54 UTC

*** This bug has been marked as a duplicate of 1828 ***