Bug 2140 - I broke TCP_NODELAY and TCP_MAXSEG
Summary: I broke TCP_NODELAY and TCP_MAXSEG
Status: RESOLVED DUPLICATE of bug 2406
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Clustering (show other bugs)
Version: 4.10.4
Hardware: PA-RISC HP-UX
: P3 normal (vote)
Target Milestone: 4.11
Assignee: Volker Lendecke
QA Contact: Samba QA Contact
URL:
Keywords:
: 2072 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-09 15:22 UTC by Richard Allen
Modified: 2019-06-11 21:24 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Allen 2004-12-09 15:22:36 UTC
I wrote a patch for 3.0.8 that fixed two warnings about macros that got
redefined on HP-UX.  I did test it on 11.00 and there it works fine, and assumed
that it would also work on all 11.X versions.
I was sadly mistaken :)
On 11.11 (11i) my patch makes TCP_NODELAY disappear as a legal socket option.

I'm fixing this as we speak and will submit it after I've tested it on 11.00,
11.11, 11.22 and 11.23 (I.e. all versions of HP-UX including and after 11.00)
Comment 1 Gerald (Jerry) Carter 2005-02-07 12:12:37 UTC
*** Bug 2072 has been marked as a duplicate of this bug. ***
Comment 2 Andrew Bartlett 2019-06-11 10:08:26 UTC
Looking at old bugs:

fc84e916f628b4fb6f6667ad45d0ced0e9134b23 is still present in the new copy of nis.h created in c29d087e1ea4c92717ef86e372fe80f410580fdc so I think this is still a real bug, even if the problematic systems are likely long dead....
Comment 3 Andrew Bartlett 2019-06-11 10:10:38 UTC

*** This bug has been marked as a duplicate of bug 2406 ***