Bug 2072 - TCP_NODELAY/TCP_MAXSEV not defined on HP-UX
Summary: TCP_NODELAY/TCP_MAXSEV not defined on HP-UX
Status: RESOLVED DUPLICATE of bug 2140
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: Build environment (show other bugs)
Version: 3.0.8
Hardware: PA-RISC HP-UX
: P3 major
Target Milestone: none
Assignee: Tim Potter
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-19 20:15 UTC by Ryan Novosielski (mail bounces back)
Modified: 2005-02-07 12:12 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Novosielski (mail bounces back) 2004-11-19 20:15:24 UTC
The problem (relating to the duplicate definition of TCP_NODELAY and 
TCP_MAXSEG) was "fixed" as a result of bug 1065. However, though the fix 
(changes to includes.h, one example being the section starting at line 312, 
another starting at line 371, and the last starting at 399) looks sane to me, 
there appears to be a problem with it. TCP_NODELAY does not get defined at all 
in my setup. I suspect the same is true of TCP_MAXSEG, but I don't know what 
that's used for, if anything. It looks like even though it is supposed to be 
getting defined 2x (and that is the reason for all of the #undef's), it seems 
to be getting #undef'd 2x also, instead of just once and then redefined.
 
Since TCP_NODELAY is reported to be a performance enhancer, I certainly don't 
want to go without it (or at least, I don't /think/ I do).
Comment 1 Ryan Novosielski (mail bounces back) 2005-02-07 11:53:54 UTC
See bug 2140 by Richard Allen.
Comment 2 Gerald (Jerry) Carter 2005-02-07 12:12:35 UTC

*** This bug has been marked as a duplicate of 2140 ***